Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#9430 closed defect (duplicate)

IOError: (13, 'Permission denied')

Reported by: idkim Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /admin/agilo/fields, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'eb4764b106c9ac5c838901e6',
 'apply': u'Apply changes',
 'cat_id': u'agilo',
 'order_businessvalue': u'14',
 'order_co_name': u'12',
 'order_drp_resources': u'2',
 'order_due_date': u'1',
 'order_i_links': u'6',
 'order_id_aux': u'4',
 'order_o_links': u'13',
 'order_platform': u'10',
 'order_rd_points': u'17',
 'order_remaining_time': u'7',
 'order_report_from': u'11',
 'order_revision': u'8',
 'order_rt_passed': u'9',
 'order_sprint': u'5',
 'order_start_date': u'0',
 'order_story_priority': u'3',
 'order_tc_id': u'15',
 'order_tc_num': u'16',
 'panel_id': u'fields',
 'path_info': None}

User Agent was: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)

System Information

Trac 0.11.4
Python 2.6.2 (release26-maint, Apr 19 2009, 02:15:38)
[GCC 4.3.3]
setuptools 0.6c9
SQLite 3.6.10
pysqlite 2.4.1
Genshi 0.5.1
mod_python 3.3.1
Agilo 0.7.4.1-r1624-20090611
Subversion 1.5.4 (r33841)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.4-py2.6.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.4-py2.6.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.4-py2.6.egg/trac/admin/web_ui.py", line 113, in process_request
    path_info)
  File "/usr/local/lib/python2.6/dist-packages/agilo-0.7.4.1_r1624_20090611-py2.6.egg/agilo/admin/api.py", line 59, in render_admin_panel
    return self.list_save_view(req, cat, page)
  File "/usr/local/lib/python2.6/dist-packages/agilo-0.7.4.1_r1624_20090611-py2.6.egg/agilo/admin/custom_fields.py", line 108, in list_save_view
    self.cfapi.update_custom_field(cur_cf)
  File "/usr/local/lib/python2.6/dist-packages/agilo-0.7.4.1_r1624_20090611-py2.6.egg/agilo/admin/custom_fields.py", line 246, in update_custom_field
    self._store_all_options_for_custom_field(customfield)
  File "/usr/local/lib/python2.6/dist-packages/agilo-0.7.4.1_r1624_20090611-py2.6.egg/agilo/admin/custom_fields.py", line 183, in _store_all_options_for_custom_field
    self.tc.save()
  File "/usr/local/lib/python2.6/dist-packages/agilo-0.7.4.1_r1624_20090611-py2.6.egg/agilo/utils/config.py", line 226, in save
    self.env.config.save()
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.4-py2.6.egg/trac/config.py", line 189, in save
    fileobj = open(self.filename, 'w')
IOError: [Errno 13] Permission denied: '/var/lib/trac/qa/conf/trac.ini'

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 12 years ago

Resolution: duplicate
Status: newclosed

InstallationIssue, duplicate of #8755 and numerous others.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.