Edgewall Software
Modify

Opened 16 years ago

Closed 14 years ago

Last modified 8 years ago

#943 closed defect (duplicate)

Problem when creating new ticket with custom fields

Reported by: pawel [no]spam rsc pl Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christopher Lenz)

Definitions in trac.ini:

   [ticket-custom]
   test_four = select
   test_four.label = Closed
   test_four.options = Not Confirmed|Confirmed

   [notification]
   smtp_replyto = trac@spamsite
   smtp_always_cc =
   smtp_server = my.smtp.server
   smtp_enabled = true
   smtp_from = myuser@mysite
   always_notify_reporter = true

When i'm submiting ticket with custom fileds the has Oops apeard:

Trac detected an internal error:
len() of unsized object

Traceback (most recent call last):
  File "/usr/local/lib/python2.3/site-packages/trac/core.py", line 525, in cgi_start
    real_cgi_start()
  File "/usr/local/lib/python2.3/site-packages/trac/core.py", line 520, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "/usr/local/lib/python2.3/site-packages/trac/core.py", line 435, in dispatch_request
    module.run()
  File "/usr/local/lib/python2.3/site-packages/trac/Module.py", line 44, in run
    self.render()
  File "/usr/local/lib/python2.3/site-packages/trac/Ticket.py", line 298, in render
    self.create_ticket()
  File "/usr/local/lib/python2.3/site-packages/trac/Ticket.py", line 290, in create_ticket
    tn.notify(ticket, newticket=1)
  File "/usr/local/lib/python2.3/site-packages/trac/Notify.py", line 189, in notify
    self.hdf.setValue('email.ticket_props', self.format_props())
  File "/usr/local/lib/python2.3/site-packages/trac/Notify.py", line 250, in format_props
    if len(tkt[f]) > width[idx+1]:
TypeError: len() of unsized object

However ticket is added to datebase but no notification is send.

Attachments (0)

Change History (4)

comment:1 by Christopher Lenz, 16 years ago

Component: generalticket system
Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #929.

comment:2 by anonymous, 14 years ago

Resolution: duplicate
Status: closedreopened

comment:3 by Alec Thomas, 14 years ago

Resolution: duplicate
Status: reopenedclosed

Please don't reopen tickets without a reason.

comment:4 by Christian Boos, 8 years ago

Milestone: 0.8

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.