Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#9414 closed defect (duplicate)

ValueError: timestamp out of range for platform localtime()/gmtime() function

Reported by: ogueye Owned by:
Priority: normal Milestone:
Component: general Version: 0.12dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /ticketcalendar, Trac issued an internal error.

(please provide additional details here)

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1045 Safari/532.5

System Information

Trac 0.12dev-r9576
Genshi 0.7dev-r1125
pysqlite 2.4.1
Python 2.6.5 (r265:79096, Mar 19 2010, 21:48:26) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.5.9
Subversion 1.6.6 (r40053)
jQuery 1.4.2

Enabled Plugins

announcerplugin 0.2
tracaccountmanager 0.2.1dev-r7737
tracganttcalendarplugin 0.1

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 512, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 233, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\ganttcalendar\ticketcalendar.py", line 122, in process_request
    due_time = to_datetime(due, utc)
  File "build\bdist.win32\egg\trac\util\datefmt.py", line 52, in to_datetime
    return datetime.fromtimestamp(t, tzinfo or localtz)
ValueError: timestamp out of range for platform localtime()/gmtime() function

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 12 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #9377. This is a good reason to upgrade to 0.12rc1 ;-)

comment:2 by Christian Boos, 12 years ago

Milestone: 0.12

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.