Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#9262 closed defect (fixed)

reassigning ticket not possible, no input or dropdown field

Reported by: daniel@… Owned by: Remy Blank
Priority: normal Milestone: 0.12
Component: ticket system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Reassigning of a ticket is not possible, there's no input or dropdown field. The "Action" fieldset looks like this instead:

Action
as new
as The resolution will be set. Next status will be 'closed'
to ??? The owner will be changed from somebody. Next status will be 'assigned'
The owner will be changed from somebody to dm. Next status will be 'accepted'

This is the logfile when showing the ticket:

2010-04-23 09:16:31,368 Trac[__init__] DEBUG: Dispatching <Request "GET '/ticket/1'">
2010-04-23 09:16:31,372 Trac[__init__] DEBUG: Retrieving session for ID u'dm'
2010-04-23 09:16:31,373 Trac[__init__] DEBUG: Negotiated locale: ['de-de', 'de', 'en-us', 'en'] -> de
2010-04-23 09:16:31,378 Trac[__init__] INFO: Synchronized '' repository in 0.01 seconds
2010-04-23 09:16:31,393 Trac[__init__] DEBUG: render_ticket_action_control: action "leave"
2010-04-23 09:16:31,393 Trac[__init__] DEBUG: render_ticket_action_control: action "resolve"
2010-04-23 09:16:31,395 Trac[__init__] DEBUG: render_ticket_action_control: action "reassign"
2010-04-23 09:16:31,395 Trac[__init__] DEBUG: render_ticket_action_control: action "accept"
2010-04-23 09:16:31,397 Trac[__init__] DEBUG: Prepare chrome data for request
2010-04-23 09:16:31,906 Trac[__init__] DEBUG: Dispatching <Request "GET '/chrome/common/css/ticket.css'">
2010-04-23 09:16:31,936 Trac[__init__] DEBUG: Dispatching <Request "GET '/chrome/site/your_project_logo.png'">
2010-04-23 09:16:31,943 Trac[__init__] WARNING: File your_project_logo.png not found in any of ['/root/trac-env/htdocs']
2010-04-23 09:16:31,944 Trac[__init__] WARNING: HTTPNotFound: 404 Not Found (File your_project_logo.png not found)
2010-04-23 09:16:31,946 Trac[__init__] DEBUG: Retrieving session for ID u'dm'
2010-04-23 09:16:31,947 Trac[__init__] DEBUG: Negotiated locale: ['de-de', 'de', 'en-us', 'en'] -> de
2010-04-23 09:16:31,952 Trac[__init__] DEBUG: Prepare chrome data for request

I can reproduce this by installing a fresh Debian Etch (debootstrap etch ./ http://ftp.de.debian.org/debian) and running this script:

#!/bin/bash

set -e
set -x

# install required packages
aptitude install python python-setuptools subversion python-pysqlite2

# get latest Genshi
svn co http://svn.edgewall.org/repos/genshi/trunk genshi

# install Genshi
cd genshi
./setup.py install
cd ..

# install babel
easy_install babel

# get latest trac
svn co http://svn.edgewall.org/repos/trac/trunk trac

# install trac
cd trac
./setup.py install
cd ..

# create a fresh env with dm as admin
trac-admin trac-env/ initenv
trac-admin trac-env/ permission add dm TRAC_ADMIN

# create file for auth (dm:dm, xy:xy)
echo dm:BsMYBICKUOdi. >> .htpasswd
echo xy:MVlS0VdJdn5CU >> .htpasswd

# run tracd
tracd --basic-auth=trac-env,.htpasswd, --port 8000 --hostname 0.0.0.0 trac-env &

exit

Then I opened trac in the browser, logged in as dm and created a ticket.

Attachments (0)

Change History (5)

comment:1 by anonymous, 10 years ago

It's the same on Debian lenny. What am I doing wrong?

comment:2 by Remy Blank, 10 years ago

Wow, that's what I call a nice bug report! Incidentally, this also happens on this Trac instance, so I can't reassign to myself :/

I wonder where those "???" come from?

comment:3 by Remy Blank, 10 years ago

This only happens when [ticket] restrict_owner = false. I guess it's due to my changes in default_workflow.py. Stay tuned…

Last edited 6 years ago by Ryan J Ollos (previous) (diff)

comment:4 by Remy Blank, 10 years ago

Milestone: 0.12
Resolution: fixed
Status: newclosed

Stupid mistake in [9507], fixed in [9525]. Thanks, and keep up the great bug reports!

comment:5 by Remy Blank, 10 years ago

Owner: set to Remy Blank

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.