Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

#9184 closed enhancement (duplicate)

Permission system slow down with restrict_owner and many users

Reported by: Ismael de Esteban <ismael@…> Owned by: Ismael de Esteban <ismael@…>
Priority: normal Milestone:
Component: general Version: 0.12dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Working in a instance with many people, and having the restrict_owner activated, trac slow down, mainly in ticket view.

I have created a patch that increases the seconds of valid cache, and flush it when any permission has changed.

This patch has been applied to versions 0.11.2(production site) and 0.11.5 with success and nothing seems to be broken, and the performance has increased a lot.

Attachments (1)

permission-cache.diff (526 bytes ) - added by Ismael de Esteban <ismael@…> 9 years ago.

Download all attachments as: .zip

Change History (2)

by Ismael de Esteban <ismael@…>, 9 years ago

Attachment: permission-cache.diff added

comment:1 by Remy Blank, 9 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #4245.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ismael de Esteban <ismael@…>.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.