Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#9156 closed enhancement (worksforme)

Capture the backspace key when editing wiki pages

Reported by: alvaro.iradier@… Owned by:
Priority: normal Milestone:
Component: wiki system Version: 0.11-stable
Severity: normal Keywords: backspace wiki edit
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Using Firefox, when editing a wiki page, if you press the backspace key when the focus is out of the text edit area, the browser moves to the previous page in history, and all the changes are lost. Moving history forward won't bring your changes back.

It would be quite nice to intercept/capture the "history back" event with javascript, and warn the user.

More info can be found here:

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 12 years ago

That's a browser quirk, suggesting wontfix.

And btw, for me it works (FF 3.6), i.e. when going forward you retrieve your edit. Maybe you have a FF plugin that gets in the way. Try disabling them. I think that this might be a problem when using https:, IIRC. But still, that would be a browser quirk. What happens with other browsers?

comment:2 by alvaro.iradier@…, 12 years ago

Using http://, Firefox 3.6 on Windows, safe mode with all extensions disabled won't remember the changes.

Internet Explorer 8, latest Opera, Chrome, and Firefox 3.0 (on Linux) however, work as expected. So I guess you're right, this is about Firefox 3.6 on Windows.

I found this on firefox bugzilla:

https://bugzilla.mozilla.org/show_bug.cgi?id=252729

Thanks.

in reply to:  2 ; comment:3 by Christian Boos, 12 years ago

Replying to alvaro.iradier@…:

Using http://, Firefox 3.6 on Windows

Same setup for me.

safe mode with all extensions disabled won't remember the changes.

Also works for me with firefox -safe-mode.

Is your Trac public?

in reply to:  3 comment:4 by alvaro.iradier@…, 12 years ago

Not public, it's our intranet Trac. Tried on other computers, and got exactly the same problem. The server is Apache 2.2.14 using Trac 0.11.7, and these are the page headers for (internal server) http://trac/rolf/wiki/Desarrollo/ProtocolSpecification?action=edit :

Date: Mon, 22 Mar 2010 10:33:29 GMT
Server: Apache/2.2.14 (Win32) DAV/2 mod_python/3.3.1 Python/2.5.4 SVN/1.6.6 mod_wsgi/3.0 Python/2.6.4 PHP/5.2.5
Cache-Control: must-revalidate
Content-Length: 15298
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html;charset=utf-8

200 Ok

BTW, just tried on another Trac site and it works! Headers are:

Date: Mon, 22 Mar 2010 11:01:18 GMT
Server: Apache/2.2.9 (Debian) mod_ssl/2.2.9 OpenSSL/0.9.8g DAV/2 SVN/1.5.1 mod_wsgi/2.5 Python/2.5.2
Cache-Control: must-revalidate
Expires: Fri, 01 Jan 1999 00:00:00 GMT
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 6586
Keep-Alive: timeout=15, max=99
Connection: Keep-Alive
Content-Type: text/html;charset=utf-8

200 Ok

Can you see something strange?

Thanks for your help, even being not a Trac issue.

Replying to cboos:

Replying to alvaro.iradier@…:

Using http://, Firefox 3.6 on Windows

Same setup for me.

safe mode with all extensions disabled won't remember the changes.

Also works for me with firefox -safe-mode.

Is your Trac public?

comment:5 by Christian Boos, 12 years ago

Milestone: 0.12
Resolution: worksforme
Status: newclosed

No idea what's going on here. If someone can provide a recipe to reproduce the issue, feel free to reopen, in the meantime there's not much we can do (and it's probably not a Trac issue in any case).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.