Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#9153 closed defect (duplicate)

IntegrityError: column name is not unique

Reported by: darenf Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.5
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /admin/ticket/milestones/Third Release, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__EDITOR__1': u'textarea',
 '__FORM_TOKEN': u'76bb1389e645d714e9282dae',
 'cat_id': u'ticket',
 'description': u'',
 'duedate': u'',
 'name': u'3rd Release',
 'panel_id': u'milestones',
 'path_info': u'Third Release',
 'save': u'Save'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

System Information

Trac 0.11.5
Python 2.4.3 (#1, Sep 3 2009, 15:37:12)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools 0.6c9
SQLite 3.3.6
pysqlite 1.1.7
Genshi 0.5.1
mod_python 3.2.8
Subversion 1.4.2 (r22196)
RPC 1.0.6
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.5-py2.4.egg/trac/web/main.py", line 444, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.5-py2.4.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.5-py2.4.egg/trac/admin/web_ui.py", line 114, in process_request
    path_info)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.5-py2.4.egg/trac/ticket/admin.py", line 44, in render_admin_panel
    return self._render_admin_panel(req, cat, page, version)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.5-py2.4.egg/trac/ticket/admin.py", line 188, in _render_admin_panel
    mil.update()
  File "/usr/lib/python2.4/site-packages/Trac-0.11.5-py2.4.egg/trac/ticket/model.py", line 714, in update
    (self.name, to_timestamp(self.due), to_timestamp(self.completed),
  File "/usr/lib/python2.4/site-packages/Trac-0.11.5-py2.4.egg/trac/db/util.py", line 59, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/sqlite/main.py", line 255, in execute
    self.rs = self.con.db.execute(SQL % parms)
IntegrityError: column name is not unique

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 12 years ago

Resolution: fixed
Status: newclosed

Duplicate of #6348.

comment:2 by Remy Blank, 12 years ago

Resolution: fixed
Status: closedreopened

Closed as duplicate, then?

comment:3 by Remy Blank, 12 years ago

Resolution: duplicate
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.