Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#9150 closed defect (duplicate)

TracError: OSError: [Errno 12] Cannot allocate memory: '/usr/lib64/python2.5'

Reported by: cyberps2@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

OS: Fedora 7 x86_64 CPU: Core 2 Duo 2.66 MEM: 4GB PYTHON : 2.5

Sometimes, when I browse my trac (0.11.3), I have the following error displayed on my web browser :

TracError: OSError: [Errno 12] Cannot allocate memory: '/usr/lib64/python2.5'

I know that the problem is similar to this one : http://trac.edgewall.org/ticket/6467

But he did not help me. In the patch which is included (here : http://bugs.python.org/issue3115), I have to replace a part of code in the file : /Modules/posixmodule.c But this file doesn't exist on my server.

How can I fix this bug ?

Attachments (0)

Change History (1)

comment:1 by Remy Blank, 10 years ago

Resolution: duplicate
Status: newclosed

Sorry, but this is not a bug in Trac. As suggested in #6467, you need to either upgrade your Python, or recompile Python from sources with the patch applied.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.