Edgewall Software
Modify

Opened 15 years ago

Closed 9 years ago

#899 closed enhancement (duplicate)

[PATCH] Allow hints for custom fields in tickets

Reported by: pkou <pkou at ua.fm> Owned by:
Priority: normal Milestone:
Component: ticket system Version: devel
Severity: normal Keywords: patch
Cc: ryano@… Branch:
Release Notes:
API Changes:

Description

Custom fields often require additional explanations for developers. It is possible to resolve this problem by adding popups that will appear when user points mouse over a custom field.

Attached patch provides a solution for this problem:

  • In trac.ini, new property field.hint can be used;
  • In generated HTML, hints are implemented using HTML title attribute.

Attachments (3)

patch-customtitle-r1036.diff (3.7 KB ) - added by pkou <pkou at ua.fm> 15 years ago.
Patch for the changes
899-custom-field-hints-r7495.patch (4.1 KB ) - added by Remy Blank 11 years ago.
Patch against trunk adding optional hints to custom ticket fields
899-custom-field-hints-r7495.2.patch (6.7 KB ) - added by Remy Blank 11 years ago.
Complete patch including unit tests

Download all attachments as: .zip

Change History (16)

by pkou <pkou at ua.fm>, 15 years ago

Patch for the changes

comment:1 by pkou <pkou at ua.fm>, 15 years ago

Note that TracTicketsCustom needs to be edited when this ticket is closed.

comment:2 by sid, 13 years ago

See also #925 and #1748.

comment:3 by Christian Boos, 13 years ago

Milestone: 0.11

Feel free to implement earlier…

comment:4 by Christian Boos, 13 years ago

Milestone: 0.110.12

0.12 I meant (i.e. not necessarily for 0.11, but why not if done part of the workflow changes…)

by Remy Blank, 11 years ago

Patch against trunk adding optional hints to custom ticket fields

comment:5 by Remy Blank, 11 years ago

Keywords: patch added
Milestone: 0.130.12
Owner: changed from Jonas Borgström to Remy Blank

The patch above adds the .hint option to custom ticket fields, and if present, adds a title attribute to the control corresponding to the field. Radio buttons are grouped in a <span> to set the title for all at once.

comment:6 by Remy Blank, 11 years ago

I forgot to update the unit tests. Here's the complete patch.

by Remy Blank, 11 years ago

Complete patch including unit tests

comment:7 by osimons, 11 years ago

I like the idea of hints - they are useful. However, I'm very unsure about adding features for custom fields until we have an idea about what the future holds for fields in general (0.13+ seems to have field refactoring on the agenda):

  • We would then have hints for custom fields, but not for regular fields.
  • 0.12 translates labels for regular fields, but not custom fields.
  • Hints (as all help) should be translatable in some way…

comment:8 by Remy Blank, 11 years ago

Milestone: 0.120.13

Re-scheduling for 0.13, as this could be in the way of i18n.

comment:9 by Remy Blank, 9 years ago

Milestone: next-major-0.1Xunscheduled
Owner: Remy Blank removed

comment:10 by Adrian Fritz <adrian@…>, 9 years ago

#925 may be related, and maybe a solution using javascript at http://trac-hacks.org/wiki/BlackMagicTicketTweaksPlugin

comment:11 by Ryan J Ollos <ryano@…>, 9 years ago

Cc: ryano@… added

comment:12 by Sebastian Krysmanski <sebastian@…>, 9 years ago

I've created a more general version of this patch (usable for all ticket fields, not just for custom fields). It's tracked here: #9648

in reply to:  12 comment:13 by Remy Blank, 9 years ago

Milestone: unscheduled
Resolution: duplicate
Status: newclosed

Replying to Sebastian Krysmanski <sebastian@…>:

I've created a more general version of this patch (usable for all ticket fields, not just for custom fields). It's tracked here: #9648

This is indeed a much improved version of the patch here. Closing as a duplicate of #9648.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.