Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#8986 closed defect (worksforme)

Error browsing Mercurial Repository

Reported by: tymtheenchanter@… Owned by: Christian Boos
Priority: normal Milestone:
Component: plugin/mercurial Version: 0.12dev
Severity: normal Keywords: repository browse
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Using Trac-0.12multirepos_r9032 and TracMercurial-0.12.0.20dev_r8964 (multirepos) creating a new environment with a named repo initially works fine, and I can browse the empty repo.

Once I have pushed to the remote repository, browsing the repository in Trac results in an error

Trac detected an internal error:
TypeError: 'mqrepo' object is unsubscriptable

Other information:

Python Traceback

Most recent call last:
File "build/bdist.linux-i686/egg/trac/web/main.py", line 495, in _dispatch_request
File "build/bdist.linux-i686/egg/trac/web/main.py", line 227, in dispatch
File "build/bdist.linux-i686/egg/trac/versioncontrol/web_ui/browser.py", line 387, in process_request
File "build/bdist.linux-i686/egg/tracext/hg/backend.py", line 426, in get_quickjump_entries

Local variables

Name	Value
b	'default'
branches	{}
branchtags	[('default', 'C\xcd\x16\xf5;?\x8a&\xe58!X\x01\x1e\xfdKR\xdb\x15\xe5')]
closed_branches	{}
n	'C\xcd\x16\xf5;?\x8a&\xe58!X\x01\x1e\xfdKR\xdb\x15\xe5'
rev	None
self	<tracext.hg.backend.MercurialRepository object at 0xba885aec>
tags	{}
tagslist	[('tip', 'C\xcd\x16\xf5;?\x8a&\xe58!X\x01\x1e\xfdKR\xdb\x15\xe5')]

System Info

Trac	0.12multirepos-r9032
Python	2.5.2 (r252:60911, Oct 5 2008, 19:42:18) [GCC 4.3.2]
setuptools	0.6c11
pytz	2008b
SQLite	3.5.9
pysqlite	2.4.1
Genshi	0.6dev-r1092
Babel	-
mod_python	3.3.1
Mercurial	1.0.1
RPC	1.0.6
jQuery	1.3.2

Enabled Plugins

TracMercurial	0.12.0.20dev-r8964	/usr/lib/python2.5/site-packages/TracMercurial-0.12.0.20dev_r8964-py2.5.egg

Attachments (0)

Change History (7)

comment:1 by Christian Boos, 13 years ago

Mercurial       1.0.1

Please upgrade, 1.0.x is only still working for the 0.10 branch of the plugin (see TracMercurial#Releases).

comment:2 by Tym The Enchanter <tymtheenchanter@…>, 13 years ago

Resolution: fixed
Status: newclosed

Obvious now you point it out!

Works perfectly now.

Many Thanks,

Tym

comment:3 by Tym The Enchanter <tymtheenchanter@…>, 13 years ago

Summary: Error browsing Mercurial Repository[SOLVED] Error browsing Mercurial Repository

comment:4 by Christian Boos, 13 years ago

Resolution: fixed
Status: closedreopened

(fixing resolution)

comment:5 by Christian Boos, 13 years ago

Milestone: 0.12-multirepos
Resolution: worksforme
Status: reopenedclosed

I'm glad that was only an InstallationIssue, thanks for reporting back after fixing it.

comment:6 by talabi00@…, 13 years ago

Resolution: worksforme
Status: closedreopened
Summary: [SOLVED] Error browsing Mercurial RepositoryError browsing Mercurial Repository

I am getting the same problem but with

System Info

User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091109 Ubuntu/9.10 (karmic)  Firefox/3.5.5
Trac   0.12multirepos-r9085
Python         2.5.2 (r252:60911, Jul 22 2009, 15:52:25) [GCC 4.2.4 (Ubuntu 4.2.4-1ubuntu3)]
setuptools     0.6c8
SQLite         3.4.2
pysqlite       2.3.2
Genshi         0.6dev-r1092
Babel  -
mod_python     3.3.1
Pygments       0.9
Subversion     1.4.6 (r28521)
Mercurial      1.0.1
jQuery 1.3.2

Enabled Plugins:

TracMercurial  0.12.0.20dev-r9083      /usr/lib/python2.5/site-packages/TracMercurial- 0.12.0.20dev_r9083-py2.5.egg
Mercurial is 1.0.1-5.1

What fix can I use to solve this?

comment:7 by Christian Boos, 13 years ago

Resolution: worksforme
Status: reopenedclosed

Upgrade Mercurial, as should have been clear from the rest of this ticket, the 1.0.1 API is no longer used in recent branches of the plugin (re-read comment:1).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.