Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#894 closed defect (worksforme)

background-icon does repeat on timeline link-hover

Reported by: peter.warasin@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: timeline Version: devel
Severity: normal Keywords: layout
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

in the section timeline, the background-images do repeat if the mouse is over the link.

here's a patch, which resolves the problem

Attachments (1)

icon_norepeat.patch (462 bytes ) - added by peter.warasin@… 15 years ago.
removes the repetition of the background-icon on mouse over

Download all attachments as: .zip

Change History (6)

by peter.warasin@…, 15 years ago

Attachment: icon_norepeat.patch added

removes the repetition of the background-icon on mouse over

comment:1 by Christopher Lenz, 15 years ago

Description: modified (diff)
Keywords: layout added
Owner: changed from Jonas Borgström to Christopher Lenz

comment:2 by Christopher Lenz, 15 years ago

I'm not able to reproduce this. What browser are you using?

comment:3 by Matthew Good <matt-good.net>, 15 years ago

I've never seen this on IE or Firefox, but it seems like this would be a browser bug since the "no-repeat" should be derived from the previous rules where it was set. However in looking over the W3C docs I noticed a caveat to be aware of with using the shortcut "background" property is that all unspecified values are set their default value which could override a previous rule.

comment:4 by peter.warasin@…, 15 years ago

i use firefox 1.0 rc1 on debian unstable debian packet: mozilla-firefox_0.99+1.0RC1-2_i386.deb

comment:5 by Christopher Lenz, 15 years ago

Resolution: worksforme
Status: newclosed

There might have been a version of Trac in SVN where this was broken. Try upgrading to the latest revision, and make sure you're not using a style sheet from the browsers cache.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.