Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8816 closed defect (fixed)

Rename a milestone instead of create a new one.

Reported by: Sondoar <ismael@…> Owned by: niels.reedijk@…
Priority: normal Milestone: 0.11.7
Component: roadmap Version: 0.11.5
Severity: normal Keywords: milestone rename patch
Cc: niels.reedijk@… Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

Steps:

  • Create a new milestone with an existing milestone name.
  • After the warning of there is already an existing milestone with that name, I change the name to a new one, and submit.
  • Then trac renames the old milestone name to the new one. And there is no new milestone created.
Trac:  	0.11.5
Python: 	2.5.4 (r254:67916, Apr 4 2009, 17:56:17) [GCC 4.3.3]
setuptools: 	0.6c9
SQLite: 	3.6.10
pysqlite: 	2.5.0
Genshi: 	0.5.1
Pygments: 	0.10
Subversion: 	1.4.6 (r28521)
jQuery:	1.2.6

Attachments (2)

trac-#8861-milestone-create.patch (801 bytes ) - added by niels.reedijk@… 10 years ago.
Patch for this problem
trac-#8861-functional-test.patch (1.5 KB ) - added by niels.reedijk@… 10 years ago.
Functional test

Download all attachments as: .zip

Change History (10)

comment:1 by Remy Blank, 10 years ago

Milestone: 0.11.6
Owner: set to Remy Blank

Ooh, bad! Confirmed here on 0.11-stable.

comment:2 by Remy Blank, 10 years ago

Milestone: 0.11.60.11.7

0.11.6 is about to start testing, so we'll do that in the next release.

by niels.reedijk@…, 10 years ago

Patch for this problem

comment:3 by anonymous, 10 years ago

Re: my patch

I'm not sure whether the logic of doing the milestone rename is clear from the flow of the code, so perhaps it needs a comment to point that out.

comment:4 by niels.reedijk@…, 10 years ago

Cc: niels.reedijk@… added
Keywords: patch added

Add patch keyword (and sort of an attempt to 'bump' the patch)

in reply to:  4 ; comment:5 by Christian Boos, 10 years ago

Description: modified (diff)

Replying to niels.reedijk@…:

Add patch keyword (and sort of an attempt to 'bump' the patch)

The "perfect" way to bump such a patch would be to add a functional test for it ;-)

See source:branches/0.11-stable/trac/ticket/tests/functional.py.

by niels.reedijk@…, 10 years ago

Functional test

in reply to:  5 comment:6 by niels.reedijk@…, 10 years ago

Replying to cboos:

Replying to niels.reedijk@…:

Add patch keyword (and sort of an attempt to 'bump' the patch)

The "perfect" way to bump such a patch would be to add a functional test for it ;-)

Here you are. As expected, it fails before the patch (because the original milestone disappeared) and it succeeds after the patch.

Enjoy!

comment:7 by Remy Blank, 10 years ago

Resolution: fixed
Status: newclosed

Patch applied in [9052]. Thanks!

comment:8 by Remy Blank, 10 years ago

Owner: changed from Remy Blank to niels.reedijk@…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain niels.reedijk@….
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from niels.reedijk@… to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.