Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#8771 closed enhancement (duplicate)

Implement commenting on changes in Trac timeline

Reported by: interstellar.condition@… Owned by:
Priority: normal Milestone:
Component: timeline Version: none
Severity: normal Keywords:
Cc: interstellar.condition@… Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

It would be nice to comment on changes in timeline. Maybe for some changes it would be redundant (tickets), but it would be very useful for changesets.

For example, someone user changes some code in changeset [3333]. You you don't understand why he did it, but it's just a little question, you don't want to make a new ticket just for that question. If you send him an email, some other potentially interested users would not see your conversation.

Here comes timeline commenting. Of course this would require changes in other parts of Trac, for example in [changeset:3333 changeset view], where all comments related to that changeset should be displayed.

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 10 years ago

Description: modified (diff)

Are you aware of #2035?

I think the idea of "commenting timeline events" should translate to "commenting on resource changes", on the resource themselves provided they allow to do such comments.

Adding that capability to more (all) resources is indeed one of the ideas motivating the GenericTrac approach.

There wouldn't be any duplication of commenting feature for the tickets, and, as you mentioned it, when viewing a changeset or anything else that has been commented upon, you'd like to have a way to see that such comments exist.

in reply to:  1 comment:2 by interstellar.condition@…, 10 years ago

I wasn't aware, thanks.

Replying to cboos:

Are you aware of #2035?

I think the idea of "commenting timeline events" should translate to "commenting on resource changes", on the resource themselves provided they allow to do such comments.

Adding that capability to more (all) resources is indeed one of the ideas motivating the GenericTrac approach.

There wouldn't be any duplication of commenting feature for the tickets, and, as you mentioned it, when viewing a changeset or anything else that has been commented upon, you'd like to have a way to see that such comments exist.

comment:3 by interstellar.condition@…, 10 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #2035

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.