Edgewall Software
Modify

Opened 12 years ago

Closed 11 years ago

#8697 closed defect (worksforme)

hg commit comments with text 'rDDD' where 'D' is a digit cause UnicodeDecodeError

Reported by: anonymous Owned by: Christian Boos
Priority: normal Milestone:
Component: plugin/mercurial Version: 0.12dev
Severity: normal Keywords: verify
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Commit comments in mercurial having text 'rDDD' where 'D' is a digit (e.g. r38720) cause a Genshi: UnicodeDecodeError where it states it's unable to find a template. This happens when clicking on 'Browse Source' and 'Timeline', preventing the use of both.

This is probably leftover from handling subversion repositories, where trac tries to parse text 'rDDD' so that it can create a link to the appropriate revision. I'm guessing trac-mercurial doesn't implement such functionality since it uses changeset hashes, so it dies with error?

To reproduce:

Create a new mercurial repository + connect a trac project.
Commit a file to repository with a comment like "initial commit at r38720".
Attempt to 'Browse Source' or look at the 'Timeline'.

Versions tested/afflicted:

trac-multirepos 0.12multirepos_r8607 + trac-mercurial 0.12.0.6dev_r8446
trac 0.11.5 + trac-mercurial 0.11.0.7

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 12 years ago

Keywords: verify added
Milestone: not applicable

comment:2 by Christian Boos, 12 years ago

Milestone: not applicablemercurial-plugin

comment:3 by Christian Boos, 11 years ago

Milestone: plugin - mercurial
Resolution: worksforme
Status: newclosed

It seems this has been fixed along the way.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.