Edgewall Software

Opened 15 years ago

Closed 15 years ago

#8689 closed defect (invalid)

Attachment not uploading to Trac

Reported by: Rocky Owned by:
Priority: high Milestone:
Component: attachment Version: none
Severity: critical Keywords: Critical sev for our project
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:


Dear Sir/Madam, I have installed a fresh instance of trac and everything works great except for attaching a file. In the logfile all it says is 1276 or any other random # and unreachable objects found. I have gone through message boards and tried to use Python 2.5 instead of 2.6 but still no avail. Please let me know if this is a legitimate bug and can be fixed….

Thanks Rocky

Attachments (0)

Change History (4)

comment:1 by Remy Blank, 15 years ago

Resolution: invalid
Status: newclosed

This sounds like an InstallationIssue. Make sure you are using 0.11.5 with Python 2.6. You will get more help on the MailingList or on the IrcChannel.

comment:2 by anonymous, 15 years ago

Resolution: invalid
Status: closedreopened

This is actually an issue on ubuntu using the package trac 0.11.1-2.1.

The errors lies within the template attachment.html of the original ubuntu 0.11.1-2.1 trac distribution. it features a hidden action value="new" field.

Additionally, in the get section of the request, there is also an action=new parameter, leading to the action parameter being interpreted as a list rather than a single value by the wsgi implementation of trac.

In fact, the value of that action parameter list is [ u'new', u'new' ].

This will always cause the AttachmentModule request handler to render the attachments list rather than processing the POST request, and, subsequently _do_save() the attachment.

comment:3 by Felix Schwarz <felix.schwarz@…>, 15 years ago

This is nothing trac can fix.

Since 0.11.4 the issue with Python 2.6 is fixed in trac (#7876). This is bug 369792 in launchpad but Ubuntu's maintainers are very slow in updating the package. Until today, the version shipped for Jaunty does not contain the fix.

Please bug the Ubuntu maintainers to update the trac package for Ubuntu Jaunty as well.

comment:4 by Remy Blank, 15 years ago

Resolution: invalid
Status: reopenedclosed

Correct, please upgrade. Closing again.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment

E-mail address and name can be saved in the Preferences .
Note: See TracTickets for help on using tickets.