Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#8687 closed defect (invalid)

IntegrityError: columns ticket, time, field are not unique

Reported by: tbrizzi Owned by:
Priority: high Milestone:
Component: ticket system Version: 0.11.5
Severity: critical Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /ticket/1, Trac issued an internal error.

As a TRAC Admin, impossible to update a ticket, i.e change the owner, the relative component, the resolution or even accept it.

Request parameters:

{'__FORM_TOKEN': u'997f03ca7c19d26121829ccd',
 'action': u'reassign',
 'action_reassign_reassign_owner': u'admin_user',
 'cnum': u'2',
 'comment': u'',
 'field_cc': u'',
 'field_component': u'component2',
 'field_description': u'',
 'field_keywords': u'',
 'field_milestone': u'',
 'field_priority': u'major',
 'field_reporter': u'admin_user',
 'field_summary': u'test ticket',
 'field_type': u'defect',
 'field_version': u'',
 'id': u'1',
 'replyto': u'',
 'submit': u'Submit changes',
 'ts': u'2009-09-18 11:42:28+00:00'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

System Information

Trac 0.11.5
Python 2.5.2 (r252:60911, Jul 22 2009, 15:50:42)
[GCC 4.2.4 (Ubuntu 4.2.4-1ubuntu3)]
setuptools 0.6c8
SQLite 3.4.2
pysqlite 2.4.0
Genshi 0.5.1
mod_python 3.3.1
Subversion 1.4.6 (r28521)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/web/main.py", line 444, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/ticket/web_ui.py", line 182, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/ticket/web_ui.py", line 508, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/ticket/web_ui.py", line 1014, in _do_save
    cnum=internal_cnum):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/ticket/model.py", line 284, in save_changes
    (self.id, when_ts, author, cnum, comment))
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/db/util.py", line 59, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "/usr/lib/python2.5/site-packages/Trac-0.11.5-py2.5.egg/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: columns ticket, time, field are not unique

Attachments (0)

Change History (2)

comment:1 by Remy Blank, 12 years ago

Keywords: needinfo added

This sounds like an InstallationIssue, as it seems to be working fine for everybody else. It almost seems like the time on your machine has stopped, otherwise at least the time column should vary across requests.

Anything special with your installation? Any plugins? Try to start with a "naked" installation, then add them back one by one.

comment:2 by Remy Blank, 12 years ago

Milestone: 0.11.6
Resolution: invalid
Status: newclosed

No reply, closing. Please reopen if you can provide more information.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.