Edgewall Software
Modify

Opened 17 years ago

Closed 16 years ago

Last modified 15 years ago

#867 closed enhancement (duplicate)

[wiki:Pagename]-style links should not require a title

Reported by: anonymous Owned by: Christian Boos
Priority: normal Milestone:
Component: wiki system Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi there

I have code formatted this text on purpose.

Sometimes people use [wiki:Entry EntryURL] in square brackets along with an entry name and URL to have a link to a Wiki entry when Trac doesn't automatically pick up the new entry and link it.

There must be a way of specifying just [wiki:Something] and have it link to that entry, without specifying the URL.

wiki:Something also works (without []) but it shows the `wiki:' prefix.

Attachments (0)

Change History (6)

comment:1 by anonymous, 17 years ago

Actually maybe I should state that not all Wiki entries are automatically converted into links. Maybe this is a bug, maybe not. I don't know. I have an entry called `OpenfilerFAQ' in my Trac environment which is not converted on a referring page although the entry exists.

comment:2 by A Different Anonymous, 17 years ago

Summary: wiki: entry should accept no link names[wiki:Pagename]-style links should not require a title

I think this ticket describes the same enhancement I would like and have changed the summary to be a bit more clear.

Writing [wiki:Somepage] should create the link Somepage. This would be useful for cases where Trac is not properly interpretting a wiki link because of surrounding text or because the wiki link isn't in camel case. For example, I would like to be able to write:

Output can be found at the path InstallRoot/output/txt

but Trac doesn't recognize InstallRoot is a wiki link when seen in that context.

This works but looks odd: [InstallRoot]/output/txt

This works but looks odd: [InstallRoot]/output/txt

Typing [wiki:InstallRoot]/output/txt doesn't work

Typing InstallRoot/output/txt doesn't work

So instead you must type [wiki:InstallRoot InstallRoot]/output/txt

So instead you must type InstallRoot/output/txt

The current required repeating of the name as a title seems overly verbose, and being able to write either [ProperWikiName] or [wiki:ProperWikiName] and get a link would be useful quite often. You might consider applying the same idea to URLs as well, for things like:

Your homepage will be available at http://www.example.com/~yourname

but that seems like something that would be needed very often.

anonymous: OpenfilerFAQ isn't a proper wiki name, so yes, you need to write it as [wiki:OpenfilerFAQ OpenfilerFAQ] (see CamelCase). OpenFilerFaq and OpenfilerFaq would both work as alternatives (but unlike some wikis, OpenFilerFAQ or OpenfilerFAQpage won't work). Most wikis seem to use the general rule that there must be at least two uppercase letters which are each followed by lowercase letters, but Trac seems to use a more strict rule of requiring at least two uppercase letters and each and every uppercase letter must be followed by lowercase letters.

comment:3 by A Different Anonymous, 17 years ago

Sorry, I meant to say splitting URLs apart seems like something that would not be needed very often.

comment:4 by Christian Boos, 16 years ago

Owner: changed from Jonas Borgström to Christian Boos
Status: newassigned

I'll try to implement this one in the InterTrac branch first.

comment:5 by Christopher Lenz, 16 years ago

cboos, please try to keep your branches focussed… putting various different changes in them will make merging a lot less likely, because peer review becomes a pain. Is there a reason this change couldn't be made in trunk?

comment:6 by Christian Boos, 16 years ago

Resolution: duplicate
Status: assignedclosed

Well, as the InterTrac branch already contains several changes on the wiki engine, I wanted to build on those.

Anyway, actually I did made that change on the trunk already (r1907). I'm getting old :)

Duplicate of #1755

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.