Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#8549 closed defect (wontfix)

unicode decode error when accessing timeline

Reported by: greer@… Owned by:
Priority: normal Milestone:
Component: timeline Version: 0.11-stable
Severity: normal Keywords: unicode
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

i have a fresh install of trac, everything seems to be working except when i access the timeline for my project.

Trac detected an internal error: UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 64: ordinal not in range(128)

File "/usr/lib/python2.5/site-packages/trac/timeline/templates/timeline.html", line 46, in <Expression u"event.render('description', context)">
  ${event.render('description', context)}
File "/usr/lib/python2.5/site-packages/trac/timeline/web_ui.py", line 288, in <lambda>
  context, field, event)
File "/usr/lib/python2.5/site-packages/trac/versioncontrol/web_ui/changeset.py", line 847, in render_timeline_event
  markup += format_to_html(self.env, context, message)
File "/usr/lib/python2.5/site-packages/trac/wiki/formatter.py", line 1095, in format_to_html
  return HtmlFormatter(env, context, wikidom).generate(escape_newlines)
File "/usr/lib/python2.5/site-packages/trac/wiki/formatter.py", line 1055, in generate
  return Markup(out.getvalue())

Attachments (0)

Change History (7)

comment:1 by Christian Boos, 10 years ago

Description: modified (diff)

Which version control backend are you using?

comment:2 by greer@…, 10 years ago

i am not exactly sure i understand the question. where do i find this information. i am using trac 0.11, running on mysql 5.0.67-0ubuntu6 on top of ubuntu 8.10

comment:3 by Christian Boos, 10 years ago

Keywords: unicode added

I meant, is the repository you're browsing a Subversion repository, a Mercurial or git one… But I guess you've answered, it's most certainly Subversion, as for the others you would have to install a dedicated plugin ;-)

Just to be sure: do you have any other plugin installed, in particular one that could interfere with the wiki formatting? If so, try disabling plugins one by one, to identify which is the problematic one, if any.

Then please try to go to the individual changesets (starting by /changeset/head, then going back), identify which one can't be displayed. Then on the command line, do svn log -r XXX -v --xml (XXX being the problematic changeset number), and post the result.

comment:4 by greer@…, 10 years ago

I found the culprit, it does have non-ascii characters in it.

<?xml version="1.0"?> <log> <logentry

revision="423">

<author>jan</author> <date>2009-07-21T08:54:28.336808Z</date> <paths> <path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap/WmlParser.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/Attribute.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/io/XmlWriter.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/kdom/TreeParser.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/parser/Tag.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/parser/ParseEvent.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/kdom/Document.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/parser/XmlParser.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/kdom</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/parser</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap/WbxmlWriter.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap/WapExtensionEvent.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/kdom/Node.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap/Wbxml.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/kdom/Element.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap/WmlWriter.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/parser/StartTag.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap/Wml.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/io/State.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/io</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/io/AbstractXmlWriter.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/XmlIO.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/PrefixMap.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/parser/AbstractXmlParser.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/wap/WbxmlParser.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/io/ParseException.java</path>

<path

action="A">/trunk/clients/j2me/trunk/NetWinPlayer/src/org/kxml/Xml.java</path>

</paths> <msg>Added items remotely

C:\Documents and Settings\Jan\桌面\org </msg> </logentry> </log>

comment:5 by Christian Boos, 10 years ago

Okay, this is nevertheless strange, as we normally take care of converting Subversion commit messages to unicode.

Is this repository public?

comment:6 by greer@…, 10 years ago

Unfortunately, we cannot make the repository public at this time.

comment:7 by Christian Boos, 10 years ago

Resolution: wontfix
Status: newclosed

Well, I can't reproduce the issue when using the commit message from comment:4. As expected, this gets properly converted to unicode.

Which version of Trac are you using exactly? Not a patched one? (there exist some unofficial "i18n" versions of 0.11).

As I can't reproduce the issue, this is something you'll going to have to debug on your own. If you find out this is indeed a problem in Trac and you've come up with a fix (or at the very least a clear indication about where Trac is misbehaving), then please reopen.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.