Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8534 closed defect (invalid)

Page loading problem with Apache mod_fastcgi and mod_deflate

Reported by: stefan@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.2.1
Severity: normal Keywords: fastcgi, apache, mod_deflate, page loading
Cc: Branch:
Release Notes:
API Changes:

Description

It seems that trac.fcgi does not work well with Apache's mod_deflate. I have the following setup with Apache 2.2.9, mod_fastcgi, on Debian lenny:

AliasMatch /trac/[^/]+/chrome/common/(.*) /usr/local/share/trac/htdocs/common/$1
AliasMatch /trac/([^/]+)/chrome/site/(.*) /srv/trac/$1/htdocs/$2
<Directory "/usr/local/share/htdocs">
  Order allow,deny
  Allow from all
</Directory>

ScriptAlias /trac /usr/local/share/trac/cgi-bin/trac.fcgi
<Location /trac>
  SetEnv TRAC_ENV_PARENT_DIR "/srv/trac"
</Location>
<LocationMatch "/trac/[^/]+/login">
  AuthType Basic
  AuthName "Trac"
  AuthUserFile /etc/apache2/svn-auth.conf
  Require valid-user
</LocationMatch>

At first glance all works well but even after the page appears completely rendered the browser keeps on loading. In a forum someone posted that deactivating mod_deflate would solve the problem which I can confirm. As I have not found any relevant information in the trac ticket system I file it here.

Using wireshark I found out that I don't get the http response codes from the server, they appear in the server's log though. After turning off mod_deflate everything works perfect.

Attachments (0)

Change History (3)

comment:1 by anonymous, 10 years ago

Resolution: invalid
Status: newclosed

It turns out that it's not a trac bug but a problem related to the specific combination of the two Apache modules involved. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=509116.

comment:2 by Christian Boos, 10 years ago

Thanks for letting us know!

It would be nice to know which versions of Apache/mod_fastcgi or mod_deflate fix the issue, or if the only solution so far is to disable mod_deflate.

in reply to:  2 comment:3 by anonymous, 10 years ago

Replying to cboos:

Thanks for letting us know!

It would be nice to know which versions of Apache/mod_fastcgi or mod_deflate fix the issue, or if the only solution so far is to disable mod_deflate.

In the Debian bug system's thread linked above they say that there are patches for mod_fastcgi in upstream but not in the packages and that mod_fcgid does not have the issue. The latter is a replacement for mod_fastcgi. Beware that it has a different configuration.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.