Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#8521 closed enhancement (duplicate)

Value for "base_url" should be supplied when creating a new environment

Reported by: boftx@… Owned by:
Priority: normal Milestone:
Component: admin/console Version: none
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The value for "base_url" is initially empty when creating a new Trac environment. I believe this should be populated if possible, probably by asking for it along with the project name. The lack of this paramter value led to a problem when I was configuring TicketMover. See http://trac-hacks.org/ticket/5560 for the discussion of that problem and how it was resolved.

It should be noted that unless you use something that depends on "base_url" being set it works just fine without a value, even in a multi-project shared .ini environment.

Attachments (0)

Change History (3)

comment:1 by Jeff Hammel <jhammel@…>, 11 years ago

If an inherited .ini file is provided, IMHO the base_url from that should be used if the inherited .ini file is not part of a project.

in reply to:  1 comment:2 by Christian Boos, 11 years ago

Replying to Jeff Hammel <jhammel@…>:

If an inherited .ini file is provided, IMHO the base_url from that should be used if the inherited .ini file is not part of a project.

That would be #7573.

comment:3 by boftx@…, 11 years ago

Resolution: duplicate
Status: newclosed

This is indeed a duplicate of #7573. After reading that ticket I agree that the patch supplied would appear to solve my issue. I'm closing this ticket accordingly.

FYI, I did a search for "base_url" and was simply overwhelmed by the number of hits, my bad for not digging deeper or trying to refine the search.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.