Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 7 years ago

#852 closed defect (duplicate)

'function' object has no attribute 'cursor'

Reported by: myroslav@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.7.1
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When trying to access http://projects.edgewall.com/trac/ticket/800 I've got:

Traceback (most recent call last):

File "/usr/lib/python2.2/site-packages/trac/ModPythonHandler.py", line 191, in handler

core.dispatch_request(mpr.path_info, args, mpr, env)

File "/usr/lib/python2.2/site-packages/trac/core.py", line 433, in dispatch_request

module.run()

File "/usr/lib/python2.2/site-packages/trac/Module.py", line 45, in run

self.render()

File "/usr/lib/python2.2/site-packages/trac/Ticket.py", line 447, in render

self.insert_ticket_data(self.req.hdf, id, ticket, reporter_id)

File "/usr/lib/python2.2/site-packages/trac/Ticket.py", line 412, in insert_ticket_data

'ticket.attachments')

File "/usr/lib/python2.2/site-packages/trac/Environment.py", line 231, in get_attachments_hdf

hdf.setValue(p + '.descr', wiki_to_oneliner(filedescription, hdf, self,self.get_db_cnx))

File "/usr/lib/python2.2/site-packages/trac/WikiFormatter.py", line 565, in wiki_to_oneliner

OneLinerFormatter(hdf, env, db, absurls).format(wikitext, out)

File "/usr/lib/python2.2/site-packages/trac/WikiFormatter.py", line 231, in format

result = re.sub(rules, self.replace, util.escape(text.strip()))

File "/usr/lib/python2.2/sre.py", line 143, in sub

return _compile(pattern, 0).sub(repl, string, count)

File "/usr/lib/python2.2/site-packages/trac/WikiFormatter.py", line 68, in replace

return getattr(self, '_' + itype + '_formatter')(match, fullmatch)

File "/usr/lib/python2.2/site-packages/trac/WikiFormatter.py", line 116, in _tickethref_formatter

cursor = self.db.cursor ()

AttributeError: 'function' object has no attribute 'cursor'

Attachments (0)

Change History (2)

comment:1 by vittorio, 15 years ago

Resolution: duplicate
Status: newclosed

this is a duplicate of #807

comment:2 by Christian Boos, 7 years ago

Milestone: 0.8

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.