Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#8467 closed defect (worksforme)

Weird behavior with search feature

Reported by: Thijs Triemstra <info@…> Owned by:
Priority: normal Milestone:
Component: search system Version: 0.11-stable
Severity: normal Keywords:
Cc: info@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I'm using Trac 0.11.5rc1. When I enter a camel-case search term in the search box it will always take me to that page, even if it doesn't exist. So searching for a ticket that contains a ValueError takes me to wiki/ValueError and it seems it doesn't search at all.

Attachments (0)

Change History (3)

comment:1 by Thijs Triemstra <info@…>, 13 years ago

Cc: info@… added

comment:2 by Emmanuel Blot, 13 years ago

Milestone: 0.11.6
Resolution: worksforme
Status: newclosed

Actually, it's not a bug, it's a feature: the search text field implements what we call the "Quick Jump" feature that allows easy access to wiki pages, tickets, changesets etc.

If you want the "true" search feature, use the "Search" button; you can disable the Quick Jump feature with the escape character: prefix the search item with the ! characters.

comment:3 by Thijs Triemstra <info@…>, 13 years ago

Thanks for the clarification and sorry for opening yet another ticket, cheers.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.