Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8415 closed defect (duplicate)

svn browser fails to open paths with whitespace ("No such node" with %20 in name)

Reported by: b100dian@… Owned by:
Priority: high Milestone:
Component: version control/browser Version: 0.11.4
Severity: normal Keywords: whitespace, space, svn, svn browser, browser
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When clicking on an SVN file/folder that has space in its name, the action fails with

"No node /path/to/file/Name%20too%20spacey.txt at revision xxx". All links correctly use %20, but supposedly trac does not unescape them.

The log file shows: "WARNING: HTTPNotFound: 404 Trac Error" following with the html error message above.

Attachments (0)

Change History (4)

comment:1 by Christian Boos, 11 years ago

Looks like a double encoding.

What web frontend (apache +mod_…, tracd, other) are you using?

Reminds me of #8128, from which this ticket is possibly a duplicate.

comment:2 by b100dian@…, 11 years ago

What web frontend (apache +mod_…, tracd, other) are you using?

Sorry for not being more specific.

I am using tracd.exe 0.11.4, through IIS 5.1 (WXPSP2), connected with AJP 1.2.28. Python is 2.5.4 (and the other corresponding libraries). SVN is 1.5.5 and the python binding is 1.6.3

(I also installed the ldap plugin (and flup and python ldap 2.3.8) but have not enabled it in [components] because I noticed I am already logged-in when enabling IIS Windows Integrated Security.)

comment:3 by Christian Boos, 11 years ago

Resolution: duplicate
Status: newclosed

Well yes, so this is indeed a duplicate of #8128.

Please pass the --unquote option to tracd.exe.

comment:4 by b100dian@…, 11 years ago

Thanks, that solved it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.