Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

#8402 closed defect (duplicate)

workflow set_owner operation doesn't work when there is only one possible owner

Reported by: ebray Owned by:
Priority: low Milestone:
Component: ticket system Version: devel
Severity: minor Keywords: workflow
Cc:
Release Notes:
API Changes:

Description

This is just an uncommon corner case, but it came up regardless.

When there is only one possible person to assign a ticket to according to the rules set by the 'set_owner' operation, the action is rendered with just text stating who the ticket will be assigned to, but no associated input element containing the actual value.

I solved this problem by including a hidden input element in the form for this case.

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by Christian Boos

Keywords: workflow added
Milestone: 0.12.1

comment:2 Changed 9 years ago by anonymous

Several forum posts indicated that this feature actually works, but didn't say how they got it to do so.

A coworker wondered aloud if this an issue with the UI, and I confirmed this is the case.

If you use

testing.operations = set_owner
testing.set_owner = test-team

in the UI, it will eat the actionname.set_owner entry.

WORKAROUND:

Manually add these entries to trac.ini from the command line, and it will honor it.

Problem is, now you can't ever use the UI again, because it will clobber your settings.

comment:3 Changed 9 years ago by anonymous

I would disagree that this is a rare case. Assign to testing is one of the examples in the WorkFlow wiki page, and it's a perfectly reasonable addition to the dev process.

Unfortunately Trac doesn't quite support Doing It Right (that is, pushing the ticket from a developer to either the test manager for doling out, or to a group account for test to cherry-pick from). It's fairly obvious from the workaround that someone intended this as a feature, but didn't quite get all of the code in agreement about how it should work.

comment:4 Changed 9 years ago by Mikael Relbe

I wonder if this ticket is related to #9002? Could someone please check if the original problem reported here still remains for Trac 0.12?

comment:5 Changed 9 years ago by Remy Blank

Milestone: next-minor-0.12.x
Resolution: duplicate
Status: newclosed

Yes, this is very likely to be a duplicate of #9002. Closing as such.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.