Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8221 closed enhancement (worksforme)

Don't add version=XX to URLs after wiki edits

Reported by: bjorn@… Owned by:
Priority: normal Milestone:
Component: wiki system Version: none
Severity: normal Keywords:
Cc: datallah@…
Release Notes:
API Changes:

Description

After saving a Trac wiki page ?version=XX gets added to the URI. This causes a lot of problems as many of our users pass these URLs around unaware that it doesn't point to the latest version.

In the old days (we upgraded to 11.x from 8.x some months ago) I don't think we had this problem, and I'd love for the old behavior to return, if only as an option.

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by datallah@…

Cc: datallah@… added

comment:2 Changed 9 years ago by Christian Boos

Milestone: 0.11.5

This has been requested numerous times, so I'll do it.

The original idea was that you could also see the change comment you've just entered, but that was probably not worth the trouble.

comment:3 Changed 9 years ago by Remy Blank

I'm confused. On my current 0.11-stable working copy, as well as on a 0.11.4 install, submitting wiki edit changes leads me to the "live" page version, i.e. without the ?version=xx. What gives?

comment:4 Changed 9 years ago by Remy Blank

Milestone: 0.11.5
Resolution: worksforme
Status: newclosed

Yep, fixed in [7650] for #7772, released as 0.11.2.

comment:5 Changed 9 years ago by Christian Boos

Quite strange, I was sure I noticed that problem a few days ago, but I can't reproduce that behavior either, now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.