Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#8211 closed defect (fixed)

Don't disown tickets when changing the component to a non-assigned one

Reported by: ChrisN@… Owned by: Remy Blank
Priority: normal Milestone: 0.11.5
Component: admin/web Version: 0.11.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

trac-admin requires owners when creating components. webadmin does not. If you create a component without an owner and change a ticket's component to that unowned component, the ticket ends up unowned as well.

Attachments (0)

Change History (6)

comment:1 by Remy Blank, 11 years ago

Being able not to specify a component owner is intentional. On this site, for example, only a few components have owners.

If you don't want to specify a component owner in trac-admin, you can pass the empty string ("") as the owner.

And yes, changing the component of a ticket will also change the owner. I think that's by design, but I'll need confirmation about that. Maybe it would make sense not to change the owner if the component owner is empty?

in reply to:  1 ; comment:2 by ChrisN@…, 11 years ago

Replying to rblank:

… And yes, changing the component of a ticket will also change the owner. I think that's by design, but I'll need confirmation about that. Maybe it would make sense not to change the owner if the component owner is empty?

Or if the ticket already has an owner. I think of the component owner as supplying the default owner for a ticket if I don't specify an owner of the ticket explicitly. Once an owner is assigned to a ticket, I wouldn't want changing the component to change the owner at all.

in reply to:  2 comment:3 by Christian Boos, 11 years ago

Milestone: 0.11.6

Replying to ChrisN@…:

Replying to rblank:

… And yes, changing the component of a ticket will also change the owner. I think that's by design, but I'll need confirmation about that. Maybe it would make sense not to change the owner if the component owner is empty?

Agreed.

Or if the ticket already has an owner. I think of the component owner as supplying the default owner for a ticket if I don't specify an owner of the ticket explicitly. Once an owner is assigned to a ticket, I wouldn't want changing the component to change the owner at all.

No, imagine the wrong component has been picked-up (not uncommon at all …), then with your suggestion, you would have to fix the owner "by hand" after fixing the component (if you know who is the component owner, that is). So I prefer to have the occasional need to revert to the previous owner (you'll always see who it was) in case the change of owner is not appropriate when you change the component.

comment:4 by Remy Blank, 11 years ago

Owner: set to Remy Blank

Ok, I'll grab that one.

comment:5 by Remy Blank, 11 years ago

Summary: Webadmin allows components wtihout ownersDon't disown tickets when changing the component to a non-assigned one

Note that the logic is slightly more complex than what is obvious. The owner only changes when changing the component if:

  • The ticket status is "new"
  • The owner is not changed by another means (e.g. re-assignment) in the same operation
  • The current owner is the owner of the old component

comment:6 by Remy Blank, 11 years ago

Milestone: 0.11.60.11.5
Resolution: fixed
Status: newclosed

With [8241], tickets are not disowned anymore when changing the component to a non-assigned component, as suggested in comment:1.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.