Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#820 closed defect (duplicate)

trac-admin won't delete lowercase permissions

Reported by: anonymous Owned by: daniel
Priority: normal Milestone:
Component: admin/console Version: devel
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

If you accidentally add a permission in lowercase it can't be deleted from the list…

Trac [e:\svnroot\test\]> permission add foo bar
Trac [e:\svnroot\test\]> permission add foo BAR
Trac [e:\svnroot\test\]> permission list

User       Action
------------------------
foo        bar
foo        BAR

Trac [e:\svnroot\test\]> permission remove foo BAR
Trac [e:\svnroot\test\]> permission remove foo bar
Trac [e:\svnroot\test\]> permission list

User       Action
------------------------
foo        bar

WinXP/Trac[955]

Attachments (0)

Change History (2)

comment:1 by Matthew Good <matt-good.net>, 15 years ago

Looks like this happened due to some changes with the intro of groups in [755].

I believe the issue is:

        if not action.islower() and not action.isupper():
            print 'group-names must be in lower case and permissions in upper case'
            return

I believe action.islower() should really be user.islower(), so that it will catch when you try to add a lowercase permission.

comment:2 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #873 (noticed too late, otherwise this would be the original and the other marked as dup).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.