Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8148 closed defect (invalid)

Does trac try to connect to external servers?

Reported by: el.baby@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.11.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Hi,

I don't read python fluently and I wouldn't know where to start.

I'm using trac 0.11.3 in an apache 2.2.8 server (using PostgreSQL).

Everything works nice, but today the server started having great delays, especially when creating new tickets… control wouldn't come back to the browser, the apache server didn't log the request but the tickets were actually being created. Funny thing is that if I hit "Preview" it worked like a charm.

The server is within our local network and, at the same time we were having problems with our ISP… we were connected but some remote things were going wilde (probably some routes were wrong at the ISP).

When the remote access were fixed, trac working nicely again… this led me to think that for some reason, trac might be trying to connecto to a remote host at least when creating a new ticket…

Is it so? Is it a configuration setting? Something I can do about it?

TIA

Attachments (0)

Change History (3)

comment:1 by Jonas Borgström, 10 years ago

Resolution: invalid
Status: newclosed

This delay is most likely caused by Trac timing out trying to connect to your mail server while sending email notifications.

The best way to avoid similar delays in the future is to install a local relaying mail server.

comment:2 by Mariano Absatz <el.baby@…>, 10 years ago

Thanx a lot… I didn't think of that and yes, we had problems with the mail server at that time… Maybe I'll install a local postfix relay.

comment:3 by Christian Boos, 10 years ago

Also check the new 0.12/TracNotification in trunk.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.