Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#8127 closed defect (invalid)

KeyError: 'fields'

Reported by: ngolovin@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /ticket/3, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'action': u'diff', 'id': u'3', 'version': u'6'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.48 Safari/525.19

System Information

Trac 0.11.3
Python 2.5.2 (r252:60911, Oct 5 2008, 19:42:18)
[GCC 4.3.2]
setuptools 0.6c9
SQLite 3.5.9
pysqlite 2.3.2
Genshi 0.6dev-r1031
mod_python 3.3.1
Subversion 1.5.1 (r32289)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/main.py", line 217, in dispatch
    self._post_process_request(req, *resp)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/web/main.py", line 311, in _post_process_request
    resp = f.post_process_request(req, *resp)
  File "/usr/lib/python2.5/site-packages/TracMasterTickets-2.1.3-py2.5.egg/mastertickets/web_ui.py", line 64, in post_process_request
    for field, field_data in change['fields'].iteritems():
KeyError: 'fields'

Attachments (0)

Change History (2)

comment:1 by ngolovin@…, 11 years ago

seems to be caused by http://trac-hacks.org/wiki/MasterTicketsPlugin (error disappears when plugin disabled)

comment:2 by Remy Blank, 11 years ago

Resolution: invalid
Status: newclosed

Please report the issue to the plugin maintainer.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.