Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#8071 closed defect (duplicate)

Unicode Anchors in TracLinks doesn't work

Reported by: Andrey.Regentov@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.3
Severity: normal Keywords: anchor, unicode, link
Cc: Branch:
Release Notes:
API Changes:

Description

When using russian (maybe any non-english) header names, Trac generates anchor names as expected. But these anchors do not work at all. I.e. clicking on anchor sign won't scroll the page and linking to anchor links just to a page, not the anchor. Example: http://mytrac.domain/wiki/MyPage#Якорь will lead to MyPage but not a "Якорь"

Attachments (0)

Change History (3)

comment:1 by Andrey.Regentov@…, 11 years ago

Oh, I forgot to point: the browser I'm using is Opera 9.63. And maybe this bug is a duplicate of #7976

comment:2 by anonymous, 11 years ago

It appears that in IE6 it works. So it's probably Opera-dependent

comment:3 by Christian Boos, 11 years ago

Resolution: duplicate
Status: newclosed

Yes, it's a duplicate of #7976.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.