Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#806 closed defect (fixed)

Milestone names need special character handling

Reported by: Brad Anderson <brad@…> Owned by: Christopher Lenz
Priority: normal Milestone: 0.9
Component: roadmap Version: devel
Severity: normal Keywords:
Cc: nepo@… Branch:
Release Notes:
API Changes:

Description

I am using revision 940 and was able to create a problem with the milestone name having a special character. My milestone name was:

Flavors / Qty issue

and after changing it to

Flavors-Qty issue

everything worked just fine.

Attachments (0)

Change History (5)

comment:1 by Brad Anderson <brad@…>, 15 years ago

Sorry, I'll add more now so you can duplicate it.

The error shows up when you are viewing the first page in the Roadmap module, and attempt to click on a milestone hyperlink to drill into the Milestone module and list the tickets.

I was unable to edit the milestone name, because I couldn't get to the milestone page. So I had to do it in the sqlite database.

comment:2 by Christopher Lenz, 15 years ago

Status: newassigned

I think the only solution to this problem would be to forbid the path separator / in milestone names. It already gets encoded properly, but it looks like Apache still parses it as a path separator and throws a generic 404… not sure why though, as Trac should be handling the request anyway.

comment:3 by Christopher Lenz, 15 years ago

Milestone: 0.8
Resolution: fixed
Status: assignedclosed

Fixed in [948].

comment:4 by Norbert Unterberg <nepo@…>, 15 years ago

Cc: nepo@… added
Milestone: 0.80.8.1
Resolution: fixed
Status: closedreopened

Edit Milestone in the web interface fails when the milestone name contains a forward slash "/".

Steps to reproduce:

  • In your web browser, go to Roadmap view.
  • Create a new milestone named "test/test" and hit the Add Milestone button.
  • The browser now displays the new milestone.
  • Hit the Edit Milestone Info button.
  • The broser displays the New Milestone instead the Edit Milestone window.

comment:5 by Christopher Lenz, 15 years ago

Milestone: 0.8.10.9
Resolution: fixed
Status: reopenedclosed

As far as I can tell, this problem isn't present in 0.8.

For trunk, it should be fixed in [1245].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.