Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#8039 closed defect (duplicate)

trac-admin fails to handle addition of duplicate permissions gracefully

Reported by: trac-bugs@… Owned by: Christian Boos
Priority: normal Milestone:
Component: admin/console Version: 0.11.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

$ trac-admin server permission add anonymous WIKI_VIEW
$ trac-admin server permission add anonymous WIKI_VIEW
Traceback (most recent call last):
  File "/usr/bin/trac-admin", line 8, in <module>
    load_entry_point('Trac==0.11.2', 'console_scripts', 'trac-admin')()
  File "//usr/lib/python2.5/site-packages/trac/admin/console.py", line 1294, in run
    return admin.onecmd(command)
  File "//usr/lib/python2.5/site-packages/trac/admin/console.py", line 123, in onecmd
    rv = cmd.Cmd.onecmd(self, line) or 0
  File "/usr/lib/python2.5/cmd.py", line 219, in onecmd
    return func(arg)
  File "//usr/lib/python2.5/site-packages/trac/admin/console.py", line 416, in do_permission
    self._do_permission_add(user, action)
  File "//usr/lib/python2.5/site-packages/trac/admin/console.py", line 453, in _do_permission_add
    self._permsys.grant_permission(user, action)
  File "//usr/lib/python2.5/site-packages/trac/perm.py", line 320, in grant_permission
    self.store.grant_permission(username, action)
  File "//usr/lib/python2.5/site-packages/trac/perm.py", line 226, in grant_permission
    (username, action))
  File "//usr/lib/python2.5/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "//usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "//usr/lib/python2.5/site-packages/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
sqlite3.IntegrityError: columns username, action are not unique

(Ticket #3873 seems to be related, but it looks like it may have only been fixed for the web frontend)

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 13 years ago

Description: modified (diff)
Milestone: 0.12
Owner: set to Christian Boos

Verified.

comment:2 by Christian Boos, 13 years ago

Milestone: 0.12
Resolution: duplicate
Status: newclosed

Oops, duplicate of #6348 of course.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.