Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#8018 closed defect (duplicate)

UnicodeDecodeError: 'ascii' codec can't decode byte 0xb4 in position 25: ordinal not in range(128)

Reported by: fai.Tsang Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.2.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /browser/HomeModel, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'path': u'/HomeModel', 'rev': u'36:a2134d171627'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.0; zh-CN; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)

System Information

Trac 0.11.2.1
Python 2.5.2 (r252:60911, Dec 2 2008, 11:31:30)
[GCC 4.1.2 (Gentoo 4.1.2 p1.0.2)]
setuptools 0.6c6
psycopg2 2.0.8
Genshi 0.5.1
Mercurial 1.0.2
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/Trac-0.11.2.1-py2.5.egg/trac/web/main.py", line 432, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib64/python2.5/site-packages/Trac-0.11.2.1-py2.5.egg/trac/web/main.py", line 204, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib64/python2.5/site-packages/Trac-0.11.2.1-py2.5.egg/trac/versioncontrol/web_ui/browser.py", line 360, in process_request
    'dir': node.isdir and self._render_dir(req, repos, node, rev),
  File "/usr/lib64/python2.5/site-packages/Trac-0.11.2.1-py2.5.egg/trac/versioncontrol/web_ui/browser.py", line 406, in _render_dir
    entries = [entry(n) for n in node.get_entries()]
  File "/usr/lib64/python2.5/site-packages/TracMercurial-0.11.0.7-py2.5.egg/tracext/hg/backend.py", line 688, in get_entries
    dirnodes = self.findnode((n_rev > node_rev) and node_rev or n_rev, dirnames)
  File "/usr/lib64/python2.5/site-packages/TracMercurial-0.11.0.7-py2.5.egg/tracext/hg/backend.py", line 596, in findnode
    if f.startswith(d):
UnicodeDecodeError: 'ascii' codec can't decode byte 0xb4 in position 25: ordinal not in range(128)

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #7799.

comment:2 by Christian Boos, 14 years ago

Rather #7160.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.