Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8016 closed enhancement (fixed)

Attachment creation may be confusing to some users

Reported by: eternalorb@… Owned by: Christian Boos
Priority: normal Milestone: 0.11.3
Component: attachment Version: none
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Take a look at http://developer.pidgin.im/ticket/8288 as a reference.

Basically what happened is I tried to add an attachment, and only saw one button after I added the attachment. "Add attachment". I assumed that meant confirm the attachment. I was wrong, and it took me back to the previous page where I added the attachment again. I noticed the link back to the actual bug in the corner this second time.

Is it possible to have a "I'm done adding attachments" or a "Take me back to my bug report" button alongside the "Add attachment" button?

Attachments (0)

Change History (5)

comment:1 by Emmanuel Blot, 11 years ago

Resolution: worksforme
Status: newclosed

Simply click on the ticket number that appears as the heading section of the attachment page.

comment:2 by Christian Boos, 11 years ago

Well, not only this, but there's also a "Back to ticket #xxx" contextual navigation link, which was added precisely because people thought the link in the heading was not obvious enough (#4701, #5428).

The Pidgin Trac runs 0.11.1 and so has this link, so obviously it's still possible to be confused… Maybe the button can simply say "Add another attachment"?

comment:3 by eternalorb@…, 11 years ago

Resolution: worksforme
Status: closedreopened

I think that changing the text of the button from "Add attachment" to "Add another attachment" would solve the problem. It indicates to the user that the system added the attachment, and signifies what that button does without confusion. The user will then think to themselves that there must be another link back to their original ticket, and find the link as I did when I realized that the button I pressed did not do what I expected.

I think perhaps this shouldn't be marked as "works for me" given that the problem isn't the lack of a link, its a potentially misleading set of information that could be improved. I found the link in the header of the Trac install, after I made the mistake the first time. Is it possible to avoid the mistake altogether?

comment:4 by Christian Boos, 11 years ago

Milestone: 0.11.3
Resolution: fixed
Severity: normalminor
Status: reopenedclosed

Fixed in r7833.

comment:5 by Christian Boos, 11 years ago

Owner: set to Christian Boos

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.