Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#7954 closed enhancement (duplicate)

WikiFormatting for ticket (custom) field values

Reported by: cucinotta@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: none
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by osimons)

Hi,

I'd like to suggest to provide the capability to see the wiki formatting syntax and automagic linking power applied to values of ticket fields as well, in addition to the description field (as it is now, AFAIK).

The motivation behind this may be seen as arising for example from the need to "formalize" the information that would be entered within a ticket single description into a set of fields with a clear and well-defined contents. This way, you would suggest to whom is entering a new ticket to split the provided information into the various elements that logically compose it (for example: general description, technical details, how to reproduce the problem, related tickets if any have been found, etc…). Also, a typical example would be to have a dedicated custom field for linking against a TRAC wiki page on which a feature is described (i.e., a requirements page, something like Requirements#R1.2).

I entered a new ticket because the only ticket I found resembling such feature is #925, but is proposes to enhance custom field labels with wiki capabilites, as opposed to (custom) field values that I am proposing instead.

Thanks, regards,

Tommaso

Attachments (0)

Change History (4)

comment:1 by osimons, 13 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

You request has already been implemented in current trunk (future 0.12) - see #1791.

comment:2 by anonymous, 13 years ago

Resolution: duplicate
Status: closedreopened

I just tried trac/trunk and in fact it works perfectly, thanks :-) However, it seems to me that the feature lacks essential documentation in the TracCustomFields manual page.

comment:3 by cucinotta@…, 13 years ago

On a related note, would it be possible to have the automagic linking feature of the WikiFormatting capability also within source code comments, so that, for example, if I put inside a C/C++ comment, something like 13 it can be linked by Trac to the corresponding ticket ? This would be useful to link source with wiki pages describing the implemented functionality, or with tickets describing what is being fixed/handled/improved by the code.

Thanks, regards,

Tommaso

in reply to:  3 comment:4 by osimons, 13 years ago

Resolution: duplicate
Status: reopenedclosed

Replying to cucinotta@…:

On a related note, would it be possible to have the automagic linking feature of the WikiFormatting capability also within source code comments…

This is not related at all…. Nor is it very useful to discuss anything on a ticket closed as a 'duplicate' as it will have to stay closed.

I'll add a note about this duplicate ticket on the original #1791, and briefly mention the missing docs there.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.