Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#7945 closed defect (invalid)

OperationalError: no such column: businessvalue

Reported by: admin Owned by: Emmanuel Blot
Priority: normal Milestone:
Component: general Version: 0.11.2.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /ticket/6, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'6d5152a9743eeb77c0bd3d0e',
 'action': u'leave',
 'cnum': u'2',
 'comment': u'',
 'field_businessvalue': u'200',
 'field_description': u'',
 'field_keywords': u'Keywords',
 'field_milestone': u'milestone2',
 'field_reporter': u'admin',
 'field_summary': u'Summery',
 'field_type': u'story',
 'id': u'6',
 'pane': u'edit',
 'replyto': u'',
 'submit': u'Submit changes',
 'ts': u'2009-01-08 08:47:44+00:00'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

System Information

Trac 0.11.2.1
Python 2.4.4 (#1, Apr 15 2008, 23:37:53)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c3
SQLite 3.3.8
pysqlite 2.3.2
Genshi 0.5.1
mod_python 3.2.10
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 432, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 204, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/ticket/web_ui.py", line 181, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.4/site-packages/agilo-0.7.2.5_r1150_20081220-py2.4.egg/agilo/ticket/web_ui.py", line 177, in _process_ticket_request
    template, data, content_type = super(AgiloTicketModule, self)._process_ticket_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/ticket/web_ui.py", line 507, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/ticket/web_ui.py", line 1005, in _do_save
    cnum=internal_cnum):
  File "/usr/lib/python2.4/site-packages/agilo-0.7.2.5_r1150_20081220-py2.4.egg/agilo/ticket/model.py", line 630, in save_changes
    res = super(AgiloTicket, self).save_changes(author, comment, when, db, cnum)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/ticket/model.py", line 273, in save_changes
    (self[name], self.id))
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: no such column: businessvalue

Attachments (0)

Change History (1)

comment:1 by Emmanuel Blot, 12 years ago

Component: notificationgeneral
Milestone: 0.10.6
Resolution: invalid
Status: newclosed

This looks like an issue with the Agilo plugin.

Try disabling this plugin, and feel free to re-open this ticket if you can reproduce this error without the plugin. Otherwise, please report the issue to the plugin maintainer.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Emmanuel Blot to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.