Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

#7801 closed defect (fixed)

0.11.2 wiki error: NameError: global name 'set' is not defined

Reported by: pmoura@… Owned by: Remy Blank
Priority: normal Milestone: 0.11.2
Component: wiki system Version: 0.11.2
Severity: blocker Keywords:
Cc:
Release Notes:
API Changes:

Description (last modified by Remy Blank)

Hi!

I've just update a 0.11.1 installation (http://trac.logtalk.org) to 0.11.2. No problems with the update. However, accessing most of the wiki pages linked from the home page gives the error:

`NameError: global name 'set' is not defined`

In the log file I found the following entry:

    self._sanitizer = TracHTMLSanitizer()
  File "/home/.purrmethius/pmoura/trac/lib/python2.3/site-packages/Trac-0.11.2-py2.3.egg/trac/util/html.py", line 29, in __init__
    safe_attrs = HTMLSanitizer.SAFE_ATTRS | set(['style'])
NameError: global name 'set' is not defined

Thanks for developing great software. Best regards,

Paulo

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by pmoura@…

Searching the web for the error message, it seems the problem is related to the use of Python 2.3. Adding the following line to the trac/util/html.py file (around line 20) seems to solve the problem:

from sets import Set as set

comment:2 Changed 9 years ago by Remy Blank

Description: modified (diff)
Owner: set to Remy Blank

Wow, that was quick… It is a bit unfortunate that this has crept in right before the release. I hope that there are not too many Trac users who still run on Python 2.3.

Anyway, it's fixed in 0.11-stable in [7667]. Thanks for the bug report. Did you have any other problems with 0.11.2 related to Python 2.3? Ideally, we should have a 2.3 build host for 0.11-stable, but I think this will be difficult.

What's the policy for such a "blocker" issue (for 2.3)? Should we tell people to install from SVN, or do we re-tag and update the release tarballs?

comment:3 Changed 9 years ago by pmoura@…

So far I've not detected any other problems in using Trac 0.11.2 with Python 2.3 but I only performed limited testing.

comment:4 Changed 9 years ago by Remy Blank

Milestone: 0.11.2
Resolution: fixed
Status: newclosed

This fix has been released as 0.11.2.1.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted.
to The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.