Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

#7742 closed defect (worksforme)

Headers and Footers missing with Genshi and Trac 0.11

Reported by: mike@… Owned by:
Priority: normal Milestone:
Component: web frontend Version: 0.11
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I've installed Trac in a couple installations and the headers and footers were completely missing. At first I thought it was a fluke, but then a friend of mine independently installed it. You can see a public example of this at http://esp.mit.edu/code/.

I've tried it on a number of different systems, compiling everything from scratch, using debian packages (except for Trac itself). Nothing got the headers to display. I've used the default configuration for 0.11, among other configurations.

Please look into this as it completely renders the majority of the system useless —- as nobody can click onto the other pages on the site.

(P.S. I really loved 0.10. Can't wait for 0.11 to work for me!)

Attachments (0)

Change History (9)

comment:1 by Christian Boos, 16 years ago

Resolution: worksforme
Status: newclosed

Did you read TracInterfaceCustomization#SiteAppearance?

If you can't find the hints there for fixing your issue, please rather ask on the trac-user MailingList, with all the relevant information included (version of Trac used, plugins (themes?), your site.html file if any, etc.).

There you will find more people able to troubleshoot your installation issues.

If it appears you've actually hit a bug in the Trac behavior, feel free to reopen that ticket.

comment:2 by mike@…, 16 years ago

Resolution: worksforme
Status: closedreopened

Hi,

This has happened on two different systems with two different people configuring Trac — with completely stock installations. Default everything, except for the subversion directory.

I've played around with the site.html for a week and that still doesn't change the fact that the bundled site.html did not work.

This is with Trac 0.11.1 and the latest trac.

comment:3 by Noah Kantrowitz, 16 years ago

What version of Genshi and what OS? This is generally caused by Genshi not processing the theme.html file.

comment:4 by mike@…, 16 years ago

I tried a couple, but the one running on esp right now is Genshi 0.5.1 python 2.5

comment:5 by mike@…, 16 years ago

The OS has varied, from Debian etch, Ubuntu 8.10, RHEL 4, and CentOS 5.

comment:6 by Christian Boos, 16 years ago

Mike, is #7463 relevant for you?

comment:7 by mike@…, 16 years ago

That looks like it might be it… I know that esp.mit.edu is in the /code/ directory, but it may be an issue with the mod_python setup?

I'll look into this when I get a chance.

comment:8 by Remy Blank, 16 years ago

Keywords: needinfo added

comment:9 by Christian Boos, 15 years ago

Resolution: worksforme
Status: reopenedclosed

Mike, by looking at http://esp.mit.edu/code/ it seems you figured out how to deal with this issue.

It would be nice if you could summarize what went wrong and/or how you fixed it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.