Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#7714 closed defect (duplicate)

Usernames with non-standard ASCII characters lead to an encoding error

Reported by: Edward Nash Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by osimons)

Having a username with a non-standard ASCII character (ä [a-umlaut] in this case) leads to the traceback below. Changing browser encoding does not solve the problem, but viewing the same page with a user with the same permissions but only normal ASCII characters in the username works fine.

Trac: 0.11.1 
Python: 2.5.2 (r252:60911, Jul 31 2008, 17:49:46) [GCC 4.2.3 (Ubuntu 4.2.3-2ubuntu7)] 
setuptools: 0.6c8 
psycopg2: 2.0.6 
Genshi: 0.5.1 
mod_python: 3.3.1 
Subversion: 1.4.6 (r28521) 
jQuery: 1.2.6 
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/api.py", line 339, in send_error
    'text/html')
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/chrome.py", line 702, in render_template
    if not req.session or not int(req.session.get('accesskeys', 0)):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/api.py", line 169, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 257, in _get_session
    return Session(self.env, req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/session.py", line 150, in __init__
    self.get_session(req.authname, authenticated=True)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/session.py", line 164, in get_session
    super(Session, self).get_session(sid, authenticated)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/session.py", line 56, in get_session
    (sid, int(authenticated)))
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: invalid byte sequence for encoding "UTF8": 0xe42020
HINT:  This error can also happen if the byte sequence does not match the encoding expected by the server, which is controlled by "client_encoding".

Attachments (0)

Change History (2)

comment:1 by osimons, 12 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #6813.

comment:2 by osimons, 12 years ago

Oops. That should have been #6318

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.