Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#7707 closed defect (worksforme)

Roadmap ical error

Reported by: marcelo.dalmas@… Owned by: Remy Blank
Priority: normal Milestone:
Component: roadmap Version: 0.10.4
Severity: normal Keywords:
Cc: marcelo.dalmas@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Remy Blank)

A error occurs when exporting a ics file from roadmap page.

Trac 0.10.5 on a Gentoo linux.

2008-10-09 15:55:29,070 Trac[main] ERROR: 'priority'
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/trac/ticket/roadmap.py", line 167, in process_request
    self.render_ics(req, db, milestones)
  File "/usr/lib/python2.5/site-packages/trac/ticket/roadmap.py", line 267, in render_ics
    priority = get_priority(ticket)
  File "/usr/lib/python2.5/site-packages/trac/ticket/roadmap.py", line 194, in get_priority
    value = priorities.get(ticket['priority'])
  File "/usr/lib/python2.5/site-packages/trac/ticket/model.py", line 104, in __getitem__
    return self.values[name]
KeyError: 'priority'

Attachments (0)

Change History (2)

comment:1 by Remy Blank, 13 years ago

Description: modified (diff)
Milestone: 0.11.3
Owner: set to Remy Blank

comment:2 by Remy Blank, 13 years ago

Milestone: 0.11.3
Resolution: worksforme
Status: newclosed

The Ticket.__getitem__() method in trac.ticket.model has changed since 0.10.4, so this should not happen anymore:

def __getitem__(self, name):
    return self.values.get(name)

The 0.10 branch is not supported anymore. Please update to the latest 0.11 and reopen if you can reproduce the issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.