Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7705 closed defect (fixed)

unit test failure with pygments 0.11.1dev

Reported by: Christian Boos Owned by: Tim Hatch
Priority: normal Milestone: 0.11.2
Component: rendering Version: 0.11-stable
Severity: normal Keywords: pygments
Cc: Branch:
Release Notes:
API Changes:

Description

Using pygments:56c3e7e93e27 (latest tip in pygments-main as of today), I get the following failure in Trac's unit tests:

FAIL: test_newline_content (trac.mimeview.tests.pygments.PygmentsRendererTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\Workspace\src\trac\repos\trunk\trac\mimeview\tests\pygments.py", line 103, in test_newline_content
    self.assertEqual("\n\n\n", t)
AssertionError: '\n\n\n' != u'\n\n\n\n'

Looking at the code, it seems that u'\n\n\n\n' should actually be the more correct result and that '\n\n\n' was the sub-optimal result we had up to now.

Tim, could you please look at this and eventually add a kind of version check to the test?

Attachments (0)

Change History (3)

comment:1 by Tim Hatch, 11 years ago

Status: newassigned

I haven't checked yet, but this is most likely caused by http://dev.pocoo.org/projects/pygments/changeset/a471fde4e814

I'll update later today.

comment:2 by Tim Hatch, 11 years ago

Resolution: fixed
Status: assignedclosed

Fixed in r7607

comment:3 by Christian Boos, 11 years ago

Milestone: 0.11-retriage0.11.2

Backported to 0.11-stable in [7616].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Tim Hatch.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Tim Hatch to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.