Edgewall Software
Modify

Opened 14 years ago

Closed 12 years ago

#7677 closed enhancement (duplicate)

Interactive preview of wiki style editing & expandable text field (wmd)

Reported by: marcandre.lureau@… Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I can't find a duplicate of this enhancement request.

I would *love* to have the interactive editing live-preview feature that stackoverflow has.

It's using WMD (markdown)

check: http://wmd-editor.com/demo

Attachments (0)

Change History (5)

comment:1 by ebray, 14 years ago

Well there's already a WYSIWYG plugin. I realize this is different (and honestly, I like this sort of thing better. Either way, it's still more likely to happen as a plugin.

(If you wanted to make it *really* cool it could include wiki macro rendering, which obviously would require XmlHttpRequests…)

comment:2 by marcandre.lureau@…, 14 years ago

Thanks for your link. Unfortunately, it's not quite the same thing, as you said.

Having the WMD approach is better, because you can't screw up the raw text format (something that any WYSIWYG would suck at). Furthermore, it's actually easier to use the markup than wysiwyg for people that are use to the formatting blocks/marks.

I don't think it requires any XmlHttpFoo, because it's only javascript client-side, afaik.

Btw, when i say "wiki style", I mean it should apply to ticket or milestone description editing as well (or any other wiki formatted content)

comment:3 by Remy Blank, 14 years ago

Milestone: 2.0

The demo looks impressive indeed. Scheduling for "incorporate alien technology" milestone. Of course, adoption might be accelerated by a working patch.

comment:4 by Christian Boos, 12 years ago

Milestone: 2.0unscheduled

Milestone 2.0 deleted

comment:5 by Remy Blank, 12 years ago

Milestone: triaging
Resolution: duplicate
Status: newclosed

Automatic preview has been implemented in #8721 for the wiki, and #8855 for ticket comments.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.