Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#7654 closed defect (duplicate)

Opposite what is stated in the help on the search topic, it is not possible to search for tickets with ticket numbers made up of less than 2 digits

Reported by: carsten.klein@… Owned by:
Priority: normal Milestone:
Component: search system Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

This "bug", however, does only exist in the search page, not in the commonly made available search form on every page.

To reproduce:

  1. click on the search button in the main navigation bar a/o leave the search field blank and simply click on the search (submit) button
  2. enter a ticket reference with a number less than 10, e.g. #[1-9]
  3. click on search
  4. trac will fail and report that at least three characters have to be entered in order to submit the search request

This seems to be an existing bug in all of the available trac releases out there

Attachments (0)

Change History (4)

comment:1 by ebray, 14 years ago

Well, that's because the search page doesn't automatically perform a "quick jump", while the quick search box does. So this is the intended behavior. I'd propose wontfix, unless this seems like it would be surprising behavior for the majority of users…

comment:2 by Christian Boos, 14 years ago

Description: modified (diff)
Milestone: not applicable
Resolution: duplicate
Status: newclosed

The problem reported here is one of the reasons why #1268 is not yet closed.

comment:3 by carsten.klein@…, 14 years ago

nevermind, i just thought that whenever you search for ticket #10 then you might always also be allowed to search for ticket #1

comment:4 by Christian Boos, 14 years ago

Indeed.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.