Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#7622 closed defect (fixed)

IndexError: tuple index out of range

Reported by: en0x Owned by: Tim Hatch
Priority: normal Milestone: 0.11.2
Component: rendering Version: 0.11
Severity: normal Keywords: pygments
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /wiki/WikiFormatting, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'page': u'WikiFormatting'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

System Information

Trac 0.11
Python 2.4.3 (#1, May 24 2008, 13:47:28)
[GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]
setuptools 0.6c8
SQLite 3.3.6
pysqlite 2.3.5
Genshi 0.5
Pygments 0.10
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/web/main.py", line 219, in dispatch
    data, content_type)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/web/chrome.py", line 726, in render_template
    stream.render(method, doctype=doctype, out=buffer)
  File "build/bdist.linux-i686/egg/genshi/core.py", line 179, in render
  File "build/bdist.linux-i686/egg/genshi/output.py", line 61, in encode
  File "build/bdist.linux-i686/egg/genshi/output.py", line 311, in __call__
  File "build/bdist.linux-i686/egg/genshi/output.py", line 753, in __call__
  File "build/bdist.linux-i686/egg/genshi/output.py", line 592, in __call__
  File "build/bdist.linux-i686/egg/genshi/output.py", line 698, in __call__
  File "build/bdist.linux-i686/egg/genshi/output.py", line 532, in __call__
  File "build/bdist.linux-i686/egg/genshi/core.py", line 283, in _ensure
  File "build/bdist.linux-i686/egg/genshi/core.py", line 283, in _ensure
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/web/chrome.py", line 779, in _strip_accesskeys
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 283, in _ensure
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/web/chrome.py", line 768, in _generate
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 569, in _include
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 299, in _match
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 299, in _match
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 246, in _match
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 543, in _exec
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 533, in _eval
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 496, in _eval
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 551, in _flatten
  File "build/bdist.linux-i686/egg/genshi/core.py", line 283, in _ensure
  File "build/bdist.linux-i686/egg/genshi/path.py", line 141, in _generate
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 569, in _include
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 235, in _strip
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 543, in _exec
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 533, in _eval
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 496, in _eval
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 551, in _flatten
  File "build/bdist.linux-i686/egg/genshi/core.py", line 283, in _ensure
  File "build/bdist.linux-i686/egg/genshi/path.py", line 141, in _generate
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 569, in _include
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 235, in _strip
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 543, in _exec
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 520, in _eval
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 286, in _eval_expr
  File "build/bdist.linux-i686/egg/genshi/template/eval.py", line 180, in evaluate
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/wiki/templates/wiki_view.html", line 37, in <Expression u'wiki_to_html(context, page.text)'>
    ${wiki_to_html(context, page.text)}
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/util/compat.py", line 133, in newfunc
    return func_(*(args + fargs), **dict(kwargs, **fkwargs))
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 1095, in format_to_html
    return HtmlFormatter(env, context, wikidom).generate(escape_newlines)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 1054, in generate
    escape_newlines)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 833, in format
    self.handle_code_block(line)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 764, in handle_code_block
    processed = self.code_processor.process(code_text)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 179, in process
    text = self.processor(text)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/wiki/formatter.py", line 170, in _mimeview_processor
    self.name, text)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/mimeview/api.py", line 606, in render
    qr = renderer.get_quality_ratio(mimetype)
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/mimeview/pygments.py", line 98, in get_quality_ratio
    self._init_types()
  File "/home/braindead/webapps/trac/lib/python2.4/Trac-0.11-py2.4.egg/trac/mimeview/pygments.py", line 181, in _init_types
    self._types[mimetype] = (aliases[0], self.QUALITY_RATIO)
IndexError: tuple index out of range

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 11 years ago

Component: generalrendering
Milestone: 0.11.2
Owner: set to Tim Hatch

Looks like you need r7485, which will be in 0.11.2.

In the meantime, simply apply the corresponding patch or upgrade to 0.11-stable.

comment:2 by Christian Boos, 11 years ago

Keywords: pygments added
Resolution: fixed
Status: newclosed

As noted above, problem fixed preemptively by Tim in r7485.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Tim Hatch.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Tim Hatch to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.