Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#7557 closed defect (worksforme)

RSS feed doesn't include port in URL

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: timeline Version: 0.11-stable
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I'm running Trac on a server using tracd and using -p to specify a port, so URL is, e.g. http://server.local:9000/project . All RSS feeds I subscribe to within that project have links http://server.local/project/… - which don't resolve properly because the port is missing. (Running on Mac OS X 10.5.4)

Attachments (0)

Change History (4)

comment:1 by Emmanuel Blot, 14 years ago

Component: generaltimeline

Weird, I can't reproduce this issue.

Have you checked your trac.ini file does not contain the project URL without a port specification?

comment:2 by steve@…, 14 years ago

[project] url is empty (as is [trac] base_url)

Apart from modifying [components] and adding [account-manager] for AccountManagerPlugin in the example project I was testing, all other settings are defaults.

comment:3 by steve@…, 14 years ago

OK, sorry, not a Trac problem. It appears to be an issue with NetNewsWire (Lite 2.0, and 3.1.6). It seems to strip the port number from URLs.

A simple curl on the command line shows port number is in the feed, and using Apple Mail also provides correct URLs.

Sorry for the inconvenience!

comment:4 by Emmanuel Blot, 14 years ago

Resolution: worksforme
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.