Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#7523 closed defect (duplicate)

[PATCH] - Query pagination fails without any filters.

Reported by: mizuno@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.11-stable
Severity: normal Keywords: needinfo verify query paginate
Cc: Branch:
Release Notes:
API Changes:

Description

How To Reproduce:

  1. Go to Custom Query.
  2. Remove any filters and update.
  3. Click any page link except page 1.
  4. You get same results as page 1 and paging link disappers.

System Information:

  • the Operating System: Solaris 10
  • the Python version used: 2.5.2
  • the database backend and their bindings: sqlite pysqlite3

Cause:

  • Query uses a previous result even if the page number changes unless query_constraints (i.e. filters) change.
  • With filters, query returns the addition of previous results and filtered results, so pagination works expectedly.
  • Without any filters, query returns just the same results as previous. It means the result has as match item as max item per page and paging link disappers.

Attachments (1)

ticket_query.diff (906 bytes ) - added by mizuno@… 11 years ago.

Download all attachments as: .zip

Change History (6)

by mizuno@…, 11 years ago

Attachment: ticket_query.diff added

comment:1 by osimons, 11 years ago

Keywords: needinfo verify added

Testing this on current 0.11-stable (r7546), and I don't see what you're seeing. I don't think the platform makes much difference either, so unless the ticket gets verified by others (or more/other information provided) there won't be any progress.

comment:2 by Christian Boos, 11 years ago

Isn't that a duplicate of #7544?

in reply to:  2 ; comment:3 by Remy Blank, 11 years ago

Replying to cboos:

Isn't that a duplicate of #7544?

Yes, it is. However, I don't understand the attachment ticket_query.diff. Does it solve another problem?

in reply to:  3 comment:4 by mizuno@…, 11 years ago

Replying to rblank:

Does it solve another problem?

That is exactly a duplicate of #7544 and the attachemnt ticket_query.diff has no intention to solve another problem. I tried to solve this problem by invoking the method query.execute(req, db) insted of query.execute(req, db, orig_list).

comment:5 by anonymous, 11 years ago

Resolution: duplicate
Status: newclosed

Ok, closing as a duplicate of #7544.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.