Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#7481 closed defect (duplicate)

Project not work affter successfull initenv

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 0.11
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:

Description

i install trac 0.11, reconfigured apache2. then i initenv new project and recive message "congratulation" and etc..

when i try open project trouth www i recive error messages

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/api.py", line 339, in send_error
    'text/html')
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/chrome.py", line 684, in render_template
    data = self.populate_data(req, data)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/chrome.py", line 592, in populate_data
    d['chrome'].update(req.chrome)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/api.py", line 168, in __getattr__
    value = self.callbacks[name](self)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/chrome.py", line 460, in prepare_request
    for category, name, text in contributor.get_navigation_items(req):
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/ticket/web_ui.py", line 133, in get_navigation_items
    if 'TICKET_CREATE' in req.perm:
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/perm.py", line 523, in has_permission
    return self._has_permission(action, resource)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/perm.py", line 537, in _has_permission
    check_permission(action, perm.username, resource, perm)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/perm.py", line 424, in check_permission
    perm)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/perm.py", line 282, in check_permission
    get_user_permissions(username)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/perm.py", line 357, in get_user_permissions
    for perm in self.store.get_user_permissions(username):
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/perm.py", line 181, in get_user_permissions
    if user in subjects:
TypeError: unhashable type: 'array.array'

Attachments (0)

Change History (5)

comment:1 by ebray <hyugaricdeau@…>, 11 years ago

Keywords: plugin needinfo added

Sounds like a problem with a plugin, since I don't think there's anything in Trac using array.array. What plugins do you have installed?

comment:2 by anonymous, 11 years ago

i not install any plugins

i just download http://ftp.edgewall.com/pub/trac/Trac-0.11.tar.gz run setup.py

and then run trac-admin /path initenv give answers to questions. recive "congratulation" message.

when i try open url with trc - i recive error message with "Traceback…."

what information i can give to you? how i can look - what plugins intslled on trac?

comment:3 by sergey@…, 11 years ago

Somebody speak in Russian? i better speak in russian :)

comment:4 by ebray <hyugaricdeau@…>, 11 years ago

Keywords: plugin removed

Actually, maybe not a plugin. Let me guess, are you using MySQL?

comment:5 by Christian Boos, 11 years ago

Resolution: duplicate
Status: newclosed

Likely duplicate of #4288, #7102. Upgrade to MySQL-python 1.2.2.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.