Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#7401 closed enhancement (wontfix)

Please lower Genshi requirement to 0.4.4

Reported by: carlos@… Owned by:
Priority: normal Milestone:
Component: web frontend Version: 0.11
Severity: normal Keywords: genshi requirement
Cc: carlos@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Someone following TracInstall would inadvertedly install Genshi ≥ 0.4.1 (I just changed the wording to reflect the 'status quo). However, when issuing trac-admin, the following error would be produced:

Traceback (most recent call last):
  File "/usr/bin/trac-admin", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2565, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: Genshi>=0.5

Is it possible to lower the requirement to support Genshi 0.4.4?

Attachments (0)

Change History (5)

comment:1 by Emmanuel Blot, 14 years ago

Severity: blockernormal

I really don't see how requesting to use the latest official release would be a blocker issue…

comment:2 by anonymous, 14 years ago

I might have misunderstood the severity levels, but it is a showstopper to anyone without access to the latest Genshi (which is why I've set it to blocker).

Considering it's only 3 weeks old, anyone without root access and a willing sysadmin cannot install Trac 0.11. By the way… is Genshi 0.5 really *needed* or is it just better because of X and Y issues?

comment:3 by Noah Kantrowitz, 14 years ago

Resolution: wontfix
Status: newclosed

Genshi 0.5 includes numerous fixes to things like memory usage. It also added the Transformer filter generator, which is used in a number of plugins. We have no intention to drop to the support level back to 0.4.4. Given that Trac 0.11 is newer than Genshi 0.5, I don't see how you would be able to upgrade one but not the other. Unless there is an actual blocker bug in Genshi 0.5, I see no reason to do this (and even then, better to release 0.5.1 and bump the req to that).

comment:4 by anonymous, 14 years ago

Understood.

in reply to:  2 comment:5 by Emmanuel Blot, 14 years ago

Keywords: 0.11 removed

Replying to anonymous:

it is a showstopper to anyone without access to the latest Genshi (which is why I've set it to blocker).

Genshi is available the same way Trac is: if you can get access to Trac, you can get access to Genshi.

Considering it's only 3 weeks old, anyone without root access and a willing sysadmin cannot install Trac 0.11.

You can install Genshi and Trac w/o root access.
Even though, not having the permissions on your environment is a bit out of scope of the Trac project.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.