Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#7393 closed defect (invalid)

TypeError: int() argument must be a string or a number, not 'NoneType'

Reported by: leon.zhang@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.11
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /revtree, Trac issued an internal error.

(please provide additional details here)

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

System Information

Trac 0.11
Python 2.5.1 (r251:54863, Apr 8 2008, 01:20:16)
[GCC 4.3.0 20080404 (Red Hat 4.3.0-6)]
setuptools 0.6c8
SQLite 3.5.6
pysqlite 2.3.2
Genshi 0.5
mod_python 3.3.1
Pygments 0.10
Subversion 1.5.0 (r31699)
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/revtree/web_ui.py", line 177, in process_request
    return self._process_revtree(req)
  File "build/bdist.linux-i686/egg/revtree/web_ui.py", line 239, in _process_revtree
    youngest = int(tracrepos.get_youngest_rev())
TypeError: int() argument must be a string or a number, not 'NoneType'

Attachments (0)

Change History (1)

comment:1 by osimons, 13 years ago

Resolution: invalid
Status: newclosed

This seems to be an issue with the trachacks:wiki:RevtreePlugin, and not Trac itself.

Please report the error at Trac-Hacks.org marked with the correct Component in order to notify the plugin maintainer.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.