Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7324 closed defect (fixed)

Firefox crashes when performing large quick search

Reported by: fermulator Owned by: Remy Blank
Priority: normal Milestone: 0.11.3
Component: search system Version: 0.11b1
Severity: normal Keywords:
Cc: fermulator@… Branch:
Release Notes:
API Changes:

Description

Steps to reproduce issue:

  1. Using Firefox…
  2. Open a trac website.
  3. Provided we have a ticket (semi-large) with several comments (20+).
  4. Copy into the clipboard a sentence (15+ words) from a comment in said ticket.
  5. In the quick search of trac, paste that large sentence and perform the search. … the results will be displayed … probably only the ONE result of that ticket since the sentence would probably be unique.
  6. Click on the link to the ticket.

trac will cause firefox to use A LOT of CPU, and the ticket could take upwards of 2+ minutes to load. Yikes!

Sometimes even firefox will crash entirely …

We suspect this has to do with syntax highlighting javascript from trac itself.

Comparison:

  1. Do a quicksearch for the TICKET NUMBER (i.e. #999)
  2. trac will automatically load the ticket, and it will be fast!

In the comparison case the only difference I can see is that there wouldn't be syntax highlighting … ?

Attachments (1)

search-limit.diff (630 bytes ) - added by Alec Thomas 11 years ago.
Limit number of highlighted words on search

Download all attachments as: .zip

Change History (7)

by Alec Thomas, 11 years ago

Attachment: search-limit.diff added

Limit number of highlighted words on search

comment:1 by Alec Thomas, 11 years ago

Give this patch a try.

comment:2 by anonymous, 11 years ago

What version of Firefox? I can't reproduce this in 2.0.0.14.

comment:3 by Remy Blank, 11 years ago

Milestone: 0.11.3
Owner: changed from Christian Boos to Remy Blank

I can reproduce this issue in Firefox 2.0.0.17, for example using #31 and following the procedure provided in the ticket description. The browser never crashes, but I get the message box about "a script taking too long" several times before the page displays.

Limiting the number of highlights sounds like a good idea.

comment:4 by Remy Blank, 11 years ago

Resolution: fixed
Status: newclosed

Fixed in [7695] by limiting highlighting to 10 terms, but also requiring terms to be at least 3 characters.

comment:5 by anonymous, 11 years ago

Owner: changed from Remy Blank to anonymous

iiourzoirhyzeoh zeo

comment:6 by Remy Blank, 11 years ago

Owner: changed from anonymous to Remy Blank

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.